First, do not take these request as fixed, we should find a clear naming and stick to it in all places in order to improve the user experiece and facilitate hudson adoption.
Here are some of the inconsistencies I found:
- job versus project
- build (action), may not be the best because not every thing you run or execute on hudson is a build.
- node versus slave
We already have a page at http://wiki.jenkins-ci.org/display/JENKINS/Terminology but this is incomplete and reading it doesn't help too much.
A good terminology should also include a list of `old terms`, terms that are outdated and to be replaced by newer variants.