Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8076

Hudson fails to install own Hudson installation when Hudson is located behind proxy

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Red Hat 5 server located behind a proxy server

      Description

      When setting up a project that uses maven on a Hudson installation behind a proxy, the installation of Maven fails with:

      "Started by user anonymous
      Unpacking http://archive.apache.org/dist/maven/binaries/apache-maven-2.2.1-bin.zip to /home/hudson/.hudson/tools on Hudson
      ERROR: Failed to parse POMs
      hudson.util.IOException2: Failed to install http://archive.apache.org/dist/maven/binaries/apache-maven-2.2.1-bin.zip to /home/hudson/.hudson/tools
      at hudson.FilePath.installIfNecessaryFrom(FilePath.java:642)
      at hudson.tools.DownloadFromUrlInstaller.performInstallation(DownloadFromUrlInstaller.java:72)
      at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:61)
      at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:99)
      at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:149)
      at hudson.tasks.Maven$MavenInstallation.forNode(Maven.java:503)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:436)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:416)
      at hudson.model.Run.run(Run.java:1324)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:349)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:139)
      Caused by: java.net.ConnectException: Connection timed out
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
      at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1458)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1452)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1106)
      at org.jvnet.robust_http_client.RetryableHttpStream.getStream(RetryableHttpStream.java:75)
      at org.jvnet.robust_http_client.RetryableHttpStream.<init>(RetryableHttpStream.java:68)
      at org.jvnet.robust_http_client.RetryableHttpStream.<init>(RetryableHttpStream.java:51)
      at hudson.FilePath.installIfNecessaryFrom(FilePath.java:628)
      ... 11 more
      Caused by: java.net.ConnectException: Connection timed out
      at java.net.PlainSocketImpl.socketConnect(Native Method)
      at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:310)
      at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:176)
      at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:163)
      at java.net.Socket.connect(Socket.java:546)
      at java.net.Socket.connect(Socket.java:495)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:174)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:409)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:530)
      at sun.net.www.http.HttpClient.<init>(HttpClient.java:240)
      at sun.net.www.http.HttpClient.New(HttpClient.java:321)
      at sun.net.www.http.HttpClient.New(HttpClient.java:338)
      at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:935)
      at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:876)
      at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:801)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1139)
      at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(HttpURLConnection.java:2214)
      at java.net.URLConnection.getHeaderFieldInt(URLConnection.java:596)
      at java.net.URLConnection.getContentLength(URLConnection.java:491)
      at org.jvnet.robust_http_client.RetryableHttpStream.<init>(RetryableHttpStream.java:67)
      ... 13 more
      Sending e-mails to: *******
      Finished: FAILURE"

      This happens even when i have:
      1) Setup Hudson to use proxy
      2) Setup a .m2/config.xml file with proxy settings

      Trying to fetch the mentioned zip file manually as the Hudson-users works fine.

        Issue Links

          Activity

          evernat evernat added a comment -

          it seems to be a duplicate of JENKINS-5271 (Connection timed out) which is fixed in Jenkins v1.432, so resolving as duplicate


            People

            • Assignee:
              Unassigned
              Reporter:
              ueland Ueland
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: