Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8480

CLONE -NullPointerException when using vss plugin

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: vss-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I am using hudson Hudson ver 1.294 with vss plugin ver 1.5
      I get this exception every now and then. Sometimes it works fine and sometimes
      fails with exceptions, without any noticeable reason. I get 2 different types of
      exceptions both originated by NullPointerException. This is one of them:

      FATAL: null
      hudson.util.IOException2
      at scm.vss.VSSSCM.getHistoryEntries(VSSSCM.java:429)
      at scm.vss.VSSSCM.getHistoryEntries(VSSSCM.java:283)
      at scm.vss.VSSSCM.checkout(VSSSCM.java:244)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:808)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:314)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:266)
      at hudson.model.Run.run(Run.java:899)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)
      Caused by: java.lang.NullPointerException
      at scm.vss.VSSSCM.getHistoryEntries(VSSSCM.java:417)
      ... 9 more

      And sometimes a slightly different exception:

      FATAL: null
      hudson.util.IOException2
      at scm.vss.VSSSCM.getHistoryEntries(VSSSCM.java:429)
      at scm.vss.VSSSCM.getHistoryEntries(VSSSCM.java:283)
      at scm.vss.VSSSCM.checkout(VSSSCM.java:244)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:808)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:314)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:266)
      at hudson.model.Run.run(Run.java:899)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)
      Caused by: java.lang.NullPointerException
      at com4j.$Proxy18.next(Unknown Source)
      at com4j.ComCollection.fetch(ComCollection.java:60)
      at com4j.ComCollection.next(ComCollection.java:38)
      at scm.vss.VSSSCM.getHistoryEntries(VSSSCM.java:416)
      ... 9 more

      Hope someone can advise.
      Thanks
      Assaf

        Attachments

          Activity

          evernat evernat added a comment -

          duplicate of JENKINS-3477


            People

            • Assignee:
              Unassigned
              Reporter:
              toowzh toowzh
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: