Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8634

VirtualBox 4.0.2 web-server became incompatible with virtualbox plugin 0.2.1

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: virtualbox-plugin
    • Labels:
      None
    • Environment:
      Windows XP 32bit (and highly likely any other environment)
    • Similar Issues:

      Description

      Upgrading VirtualBox from the former version 3.2 to 4.0.2 broke the virtualbox-plugin. To be more precise, the plugin can no longer connect to the virtualbox-cloud using the http server (vboxwebsrv).

      The virtualbox-webserver is started with:
      1) VBoxManage setproperty websrvauthlibrary null
      2) vboxwebsrv

      When testing the connection to the cloud from inside Hudson system-settings, the following error messages is printed:
      "HTTP transport error: java.net.ConnectException: Connection refused: connect"

      And the main Hudson log shows no exception dump or whatsoever, only the INFO message:
      "INFO: Testing connection to http://csgwfcl185:18083/virtualbox with username CISystem"

      Instead when trying to startup a slave-node explictly, the following exception-dump is printed:

      FATAL: HTTP transport error: java.net.ConnectException: Connection refused: connect
      com.sun.xml.internal.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused: connect
      at com.sun.xml.internal.ws.transport.http.client.HttpClientTransport.getOutput(HttpClientTransport.java:121)
      at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:142)
      at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.processRequest(HttpTransportPipe.java:83)
      at com.sun.xml.internal.ws.transport.DeferredTransportPipe.processRequest(DeferredTransportPipe.java:105)
      at com.sun.xml.internal.ws.api.pipe.Fiber.__doRun(Fiber.java:587)
      at com.sun.xml.internal.ws.api.pipe.Fiber._doRun(Fiber.java:546)
      at com.sun.xml.internal.ws.api.pipe.Fiber.doRun(Fiber.java:531)
      at com.sun.xml.internal.ws.api.pipe.Fiber.runSync(Fiber.java:428)
      at com.sun.xml.internal.ws.client.Stub.process(Stub.java:211)
      at com.sun.xml.internal.ws.client.sei.SEIStub.doProcess(SEIStub.java:124)
      at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:98)
      at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:78)
      at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:107)
      at $Proxy47.iWebsessionManagerLogon(Unknown Source)
      at com.sun.xml.ws.commons.virtualbox_3_1.IWebsessionManager.logon(IWebsessionManager.java:255)
      at hudson.plugins.virtualbox.VirtualBoxUtils.connect(VirtualBoxUtils.java:29)
      at hudson.plugins.virtualbox.VirtualBoxUtils.getMachines(VirtualBoxUtils.java:39)
      at hudson.plugins.virtualbox.VirtualBoxCloud.retrieveMachines(VirtualBoxCloud.java:56)
      at hudson.plugins.virtualbox.VirtualBoxCloud.getVirtualMachines(VirtualBoxCloud.java:61)
      at hudson.plugins.virtualbox.VirtualBoxPlugin.getVirtualBoxMachine(VirtualBoxPlugin.java:94)
      at hudson.plugins.virtualbox.VirtualBoxComputerLauncher.launch(VirtualBoxComputerLauncher.java:40)
      at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:184)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.net.ConnectException: Connection refused: connect
      at java.net.PlainSocketImpl.socketConnect(Native Method)
      at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
      at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
      at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
      at java.net.Socket.connect(Socket.java:529)
      at java.net.Socket.connect(Socket.java:478)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:163)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
      at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
      at sun.net.www.http.HttpClient.New(HttpClient.java:306)
      at sun.net.www.http.HttpClient.New(HttpClient.java:323)
      at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:975)
      at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:954)
      at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:841)
      at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1019)
      at com.sun.xml.internal.ws.transport.http.client.HttpClientTransport.getOutput(HttpClientTransport.java:109)
      ... 26 more

        Attachments

          Activity

          mmzik Michael Mzik added a comment -

          typos removed

          choas Lars Gregori added a comment -

          I have a fix on github : https://github.com/choas/virtualbox4-plugin ... I've also uploaded the .hpi file to github (see Download button).

          Code is based on https://github.com/jenkinsci/virtualbox-plugin and I've modified VirtualBoxUtils.java which uses the VirtualBox 4.x API. That's the reason I've also renamed the plugin from virtualbox to virtualbox4. I've tested it on VirtualBox 4.0.4 ... but couldn't test it on a 3.x Version, so I'm not sure if virtualbox4 is downwards compatible.

          choas Lars Gregori added a comment - - edited
          aheritier Arnaud Héritier added a comment -

          The issue mustn't be marked as solved because the problem always exists in the official plugin delivered from the update center.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Lars Gregori
          Path:
          .gitignore
          client/pom.xml
          client/src/main/java/hudson/plugins/virtualbox/Client.java
          lib/org/virtualbox/readme.txt
          lib/org/virtualbox/vboxws-40/4.0.8/vboxws-40-4.0.8.jar
          lib/org/virtualbox/vboxws-40/4.0.8/vboxws-40-4.0.8.jar.md5
          lib/org/virtualbox/vboxws-40/4.0.8/vboxws-40-4.0.8.jar.sha1
          lib/org/virtualbox/vboxws-40/4.0.8/vboxws-40-4.0.8.pom
          lib/org/virtualbox/vboxws-40/4.0.8/vboxws-40-4.0.8.pom.md5
          lib/org/virtualbox/vboxws-40/4.0.8/vboxws-40-4.0.8.pom.sha1
          lib/org/virtualbox/vboxws-40/maven-metadata.xml
          lib/org/virtualbox/vboxws-40/maven-metadata.xml.md5
          lib/org/virtualbox/vboxws-40/maven-metadata.xml.sha1
          lib/org/virtualbox/vboxws-41/4.1.8/vboxws-41-4.1.8.jar
          lib/org/virtualbox/vboxws-41/4.1.8/vboxws-41-4.1.8.jar.md5
          lib/org/virtualbox/vboxws-41/4.1.8/vboxws-41-4.1.8.jar.sha1
          lib/org/virtualbox/vboxws-41/4.1.8/vboxws-41-4.1.8.pom
          lib/org/virtualbox/vboxws-41/4.1.8/vboxws-41-4.1.8.pom.md5
          lib/org/virtualbox/vboxws-41/4.1.8/vboxws-41-4.1.8.pom.sha1
          lib/org/virtualbox/vboxws-41/maven-metadata.xml
          lib/org/virtualbox/vboxws-41/maven-metadata.xml.md5
          lib/org/virtualbox/vboxws-41/maven-metadata.xml.sha1
          plugin/pom.xml
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxBuildWrapper.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxCloud.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxComputer.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxComputerLauncher.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxControl.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxControlV31.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxControlV40.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxControlV41.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxLogger.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxMachine.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxPlugin.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxSlave.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxSystemLog.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxTaskListenerLog.java
          plugin/src/main/java/hudson/plugins/virtualbox/VirtualBoxUtils.java
          plugin/src/main/resources/index.jelly
          pom.xml
          http://jenkins-ci.org/commit/virtualbox-plugin/0ff35af96e8cc1189fc2c4382b41dae024fba927
          Log:
          Merge pull request #1 from mihais/JENKINS-8634

          Add support for VirtualBox 4

          Compare: https://github.com/jenkinsci/virtualbox-plugin/compare/4927592...0ff35af

          choas Lars Gregori added a comment -

          Version 0.4.4 available as official plugin. This version integrates Virtualbox 3.x, 4.0 and 4.1.

          choas Lars Gregori added a comment -

          Version 0.4.4 is official available and integrates VirtualBox 3.x, 4.0 and 4.1.


            People

            • Assignee:
              choas Lars Gregori
              Reporter:
              mmzik Michael Mzik
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: