Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9250

Clone workspace does not work well with multiple scm plugin

    Details

    • Similar Issues:

      Description

      Currently the plugin will clean the destination workspace before the cloned workspace is copied there. This is problematic when the job uses the Multiple SCM plugin in to get another set of sources, even if set up correctly this leads to a complete checkout of all of the other sources for each invokation of the build.
      I guess allowing the user to choose to unzip the cloned workspace into a directory and to only clear this directory before copying might solve the problem.

      While one might argue that such an option might be better located in the multiple SCM plugin, other SCM plugins like SVN offer such an option. (Besides this option could be useful if cloning workspaces from more than one job will be possible)

        Attachments

          Activity

          Hide
          whimboo Henrik Skupin added a comment -

          We hit this issue too in our ci system. abayer, given that you are assigned do you have any news about a possible fix?

          Show
          whimboo Henrik Skupin added a comment - We hit this issue too in our ci system. abayer, given that you are assigned do you have any news about a possible fix?
          Hide
          tfischer Thierry Fischer added a comment -

          We also have this issue, and this prevent us to use that plugin, instead we copy directly with the file path (but it does not work when jobs are not executed on the same machine).

          Show
          tfischer Thierry Fischer added a comment - We also have this issue, and this prevent us to use that plugin, instead we copy directly with the file path (but it does not work when jobs are not executed on the same machine).
          Hide
          cbeikov Christian Beikov added a comment -

          Same problem here, hope this will be fixed soon!

          Show
          cbeikov Christian Beikov added a comment - Same problem here, hope this will be fixed soon!
          Hide
          millergarym millergarym added a comment -

          Same issue. I'm a trying to use this plug-in to aggregated the artifacts from multiple other build. My work around is to do a wget of lastest builds' artifacts.
          Would be nice if this plug had a checkbox to just use the same glob as the artifacts.

          Show
          millergarym millergarym added a comment - Same issue. I'm a trying to use this plug-in to aggregated the artifacts from multiple other build. My work around is to do a wget of lastest builds' artifacts. Would be nice if this plug had a checkbox to just use the same glob as the artifacts.

            People

            • Assignee:
              abayer Andrew Bayer
              Reporter:
              pushy Michael Pisula
            • Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated: