Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-947

Email is sent for unstable builds even if the "Send e-mail for every unstable build" is not checked

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Ive enabled email configuration for a job with the following configuration:
      Recipients: <my email address>
      Send e-mail for every unstable build [NOT CHECKED]
      Send separate e-mails to individuals who broke the build [CHECKED]

      We only have unstable builds currently, and when someone checks in code that
      does not break the build (ie it is still unstable, but not failed) then they
      receive an email containing this:
      -----------------------------------------------------------------
      Hudson build is back to stable: Eads Ns1 CI Build #566
      See http://vkmws33/job/xyzBuild/566/changes
      -----------------------------------------------------------------

      The email should not say that the build is stable as it is unstable.
      Hudson should not send an email as Ive asked it to not send emails for unstable
      builds.

      The console contains the following info
      -----------------------------------------------------------------
      C:\Hudson\data\jobs\xyzBuild\workspace>exit 0
      Sending e-mails to: qrameri egsmd@aaaa
      Transforming NUnit tests results
      Recording test results
      finished: UNSTABLE
      -----------------------------------------------------------------

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          This is an NUnit plugin issue. I committed a fix for NUnit plugin 0.3.

          The problem is that NUnit plugin runs after e-mail notification plugin, as
          evident in the console output, so when the e-mail plugin gets to work the build
          was still successful.


            People

            • Assignee:
              Unassigned
              Reporter:
              redsolo redsolo
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: