Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9634

Reopen: OS X builds on 1.409 always fail with a ProcessTreeKiller error

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Same problem as desrcibed in issues: https://issues.jenkins-ci.org/browse/JENKINS-3164 and https://issues.jenkins-ci.org/browse/JENKINS-6423.

      FATAL: Bounds exceeds available space : size=262144, offset=262145
      java.lang.IndexOutOfBoundsException: Bounds exceeds available space : size=262144, offset=262145
      at com.sun.jna.Memory.boundsCheck(Memory.java:168)
      at com.sun.jna.Memory.getByte(Memory.java:394)
      at hudson.util.ProcessTree$Darwin$DarwinProcess$1StringArrayMemory.skip0(ProcessTree.java:1005)
      at hudson.util.ProcessTree$Darwin$DarwinProcess.parse(ProcessTree.java:1058)
      at hudson.util.ProcessTree$Darwin$DarwinProcess.getEnvironmentVariables(ProcessTree.java:948)
      at hudson.util.ProcessTree$OSProcess.hasMatchingEnvVars(ProcessTree.java:266)
      at hudson.util.ProcessTree$Unix.killAll(ProcessTree.java:482)
      at hudson.Launcher$LocalLauncher.kill(Launcher.java:721)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:446)
      at hudson.model.Run.run(Run.java:1362)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:145)

      on
      uname -a
      Darwin TheMini.local 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 15:17:16 PST 2011; root:xnu-1504.9.37~1/RELEASE_I386 i386

        Attachments

          Activity

          ryangardner ryangardner added a comment - - edited

          I'm also seeing this issue on an OS X build server -

          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 5:56.465s
          [INFO] Finished at: Wed May 25 11:50:19 MDT 2011
          [INFO] Final Memory: 87M/505M
          [INFO] ------------------------------------------------------------------------
          channel stopped
          FATAL: Failed to parse arguments: arg0=/usr/bin/perl5.10.0, arguments=[amavisd (virgin child)], nargs=4
          java.lang.IllegalStateException: Failed to parse arguments: arg0=/usr/bin/perl5.10.0, arguments=[amavisd (virgin child)], nargs=4
          at hudson.util.ProcessTree$Darwin$DarwinProcess.parse(ProcessTree.java:1063)
          at hudson.util.ProcessTree$Darwin$DarwinProcess.getEnvironmentVariables(ProcessTree.java:948)
          at hudson.util.ProcessTree$OSProcess.hasMatchingEnvVars(ProcessTree.java:266)
          at hudson.util.ProcessTree$Unix.killAll(ProcessTree.java:482)
          at hudson.Launcher$LocalLauncher.kill(Launcher.java:721)
          at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:452)
          at hudson.model.Run.run(Run.java:1374)
          at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:467)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:145)
          Caused by: java.lang.IndexOutOfBoundsException: Bounds exceeds available space : size=262144, offset=262145
          at com.sun.jna.Memory.boundsCheck(Memory.java:168)
          at com.sun.jna.Memory.getByte(Memory.java:394)
          at hudson.util.ProcessTree$Darwin$DarwinProcess$1StringArrayMemory.skip0(ProcessTree.java:1005)
          at hudson.util.ProcessTree$Darwin$DarwinProcess.parse(ProcessTree.java:1059)
          ... 9 more

          Even though the maven build succeeds this bug causes it to mark the build as a failure.

          I'm not sure when this issue started as I just fired up the jenkins server to start doing builds.

          uname -a output:

          Darwin apollo.biipr.com 10.6.0 Darwin Kernel Version 10.6.0: Wed Nov 10 18:11:58 PST 2010; root:xnu-1504.9.26~3/RELEASE_X86_64 x86_64

          frozenskys Richard Cooper added a comment -

          Getting this on Lion as well with Jenkins 1.427

          I can confirm that running with hudson.util.ProcessTreeKiller.disable=true is a workaround, but it looks like my builds may now be leaking processes

          uname -a output:

          Darwin Elizabeth.local 11.2.0 Darwin Kernel Version 11.2.0: Tue Aug 9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64 x86_64

          giladbu Gilad Buchman added a comment -

          seeing it also on 1.420

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          core/src/main/java/hudson/util/ProcessTree.java
          http://jenkins-ci.org/commit/jenkins/550678074ebeae884cf98850c4032141a936fe09
          Log:
          [FIXED JENKINS-9634] fixed a bug in the Mac OS X arg parsing code

          kohsuke Kohsuke Kawaguchi added a comment -

          Also see discussion of this in https://github.com/jenkinsci/jenkins/pull/224

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          core/src/main/java/hudson/util/ProcessTree.java
          http://jenkins-ci.org/commit/jenkins/92b98ba43c2637276911b241c8223a91a2191385
          Log:
          pointing people who saw this to JENKINS-9634

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #1275
          [FIXED JENKINS-9634] fixed a bug in the Mac OS X arg parsing code
          pointing people who saw this to JENKINS-9634

          Kohsuke Kawaguchi : 550678074ebeae884cf98850c4032141a936fe09
          Files :

          • changelog.html
          • core/src/main/java/hudson/util/ProcessTree.java

          Kohsuke Kawaguchi : 92b98ba43c2637276911b241c8223a91a2191385
          Files :

          • core/src/main/java/hudson/util/ProcessTree.java

            People

            • Assignee:
              Unassigned
              Reporter:
              wrtsprt Raphael Doehring
            • Votes:
              2 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: