Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu 10.10 i386, AWS EC2 instance (ami-fb9ca98f c1.medium)
    • Similar Issues:

      Description

      Version 1.411 works fine, upgrade to 1.412 breaks jenkins. The webconsole does not open anymore (I run it behind apache2 proxy, but direct access doesn't work either). Top shows that it keeps adding jenkins processes (/usr/bin/java -jar /usr/share/jenkins/jenkins.war --webroot=/var/run/jenkins/war --httpPort=8080 --ajp13Port=-1 ), one is always running at ~65% CPU all the time. I had it running for a while now but the webinterface doesn't come up. My solution was to reverted to the previous version, that version worked great anyway.

      The following appears in the log:

      Running from: /usr/share/jenkins/jenkins.war
      [Winstone 2011/05/17 20:10:38] - Beginning extraction from war file
      hudson home directory: /var/lib/jenkins found at: EnvVars.masterEnvVars.get("JENKINS_HOME")
      [Winstone 2011/05/17 20:10:40] - HTTP Listener started: port=8080
      Using one-time self-signed certificate
      17-May-2011 20:10:41 hudson.model.Hudson$5 onAttained
      INFO: Started initialization
      [Winstone 2011/05/17 20:10:41] - Winstone Servlet Engine v0.9.10 running: controlPort=disabled
      17-May-2011 20:10:42 hudson.model.Hudson$5 onAttained
      INFO: Listed all plugins
      17-May-2011 20:10:42 hudson.plugins.greenballs.PluginImpl start
      INFO: Green Balls!
      17-May-2011 20:10:46 hudson.model.Hudson$5 onAttained
      INFO: Prepared all plugins
      17-May-2011 20:15:20 hudson.model.Hudson$5 onTaskFailed
      SEVERE: Failed Initializing plugin git
      java.lang.StackOverflowError
      at java.lang.StringCoding.deref(StringCoding.java:64)
      at java.lang.StringCoding.encode(StringCoding.java:276)
      at java.lang.String.getBytes(String.java:954)
      at java.io.UnixFileSystem.getBooleanAttributes0(Native Method)
      at java.io.UnixFileSystem.getBooleanAttributes(UnixFileSystem.java:243)
      at java.io.File.exists(File.java:750)
      at sun.misc.URLClassPath$FileLoader.getResource(URLClassPath.java:999)
      at sun.misc.URLClassPath.getResource(URLClassPath.java:185)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:209)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at winstone.classLoader.WebappClassLoader.loadClass(WebappClassLoader.java:68)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:314)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:314)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
      at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
      at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:426)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:314)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
      at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:641)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:641)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:204)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:277)
      at hudson.ExtensionList.load(ExtensionList.java:237)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:208)
      at hudson.ExtensionList.iterator(ExtensionList.java:115)
      at hudson.model.Hudson.getDescriptorByType(Hudson.java:1003)
      at hudson.tasks.Mailer.descriptor(Mailer.java:143)
      at hudson.model.Hudson.getRootUrl(Hudson.java:1806)
      at hudson.plugins.clover.CloverBuildWrapper$DescriptorImpl.getDisplayName(CloverBuildWrapper.java:122)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:80)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:36)
      at java.util.Arrays.mergeSort(Arrays.java:1157)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1168)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.sort(Arrays.java:1092)
      at java.util.Collections.sort(Collections.java:134)
      at hudson.ExtensionList.sort(ExtensionList.java:249)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:210)
      at hudson.ExtensionList.iterator(ExtensionList.java:115)
      at hudson.model.Hudson.getDescriptorByType(Hudson.java:1003)
      at hudson.tasks.Mailer.descriptor(Mailer.java:143)
      at hudson.model.Hudson.getRootUrl(Hudson.java:1806)
      at hudson.plugins.clover.CloverBuildWrapper$DescriptorImpl.getDisplayName(CloverBuildWrapper.java:122)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:80)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:36)
      at java.util.Arrays.mergeSort(Arrays.java:1157)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1168)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.sort(Arrays.java:1092)
      at java.util.Collections.sort(Collections.java:134)
      at hudson.ExtensionList.sort(ExtensionList.java:249)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:210)
      at hudson.ExtensionList.iterator(ExtensionList.java:115)
      at hudson.model.Hudson.getDescriptorByType(Hudson.java:1003)
      at hudson.tasks.Mailer.descriptor(Mailer.java:143)
      at hudson.model.Hudson.getRootUrl(Hudson.java:1806)
      at hudson.plugins.clover.CloverBuildWrapper$DescriptorImpl.getDisplayName(CloverBuildWrapper.java:122)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:80)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:36)
      at java.util.Arrays.mergeSort(Arrays.java:1157)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)

      repeats ...

      at java.util.Arrays.mergeSort(Arrays.java:1157)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1168)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.sort(Arrays.java:1092)
      at java.util.Collections.sort(Collections.java:134)
      at hudson.ExtensionList.sort(ExtensionList.java:249)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:210)
      at hudson.ExtensionList.iterator(ExtensionList.java:115)
      at hudson.model.Hudson.getDescriptorByType(Hudson.java:1003)
      at hudson.tasks.Mailer.descriptor(Mailer.java:143)
      at hudson.model.Hudson.getRootUrl(Hudson.java:1806)
      at hudson.plugins.clover.CloverBuildWrapper$DescriptorImpl.getDisplayName(CloverBuildWrapper.java:122)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:80)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:36)
      at java.util.Arrays.mergeSort(Arrays.java:1157)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1168)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.sort(Arrays.java:1092)
      at java.util.Collections.sort(Collections.java:134)
      at hudson.ExtensionList.sort(ExtensionList.java:249)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:210)
      at hudson.ExtensionList.iterator(ExtensionList.java:115)
      at hudson.model.Hudson.getDescriptorByType(Hudson.java:1003)
      at hudson.tasks.Mailer.descriptor(Mailer.java:143)
      at hudson.model.Hudson.getRootUrl(Hudson.java:1806)
      at hudson.plugins.clover.CloverBuildWrapper$DescriptorImpl.getDisplayName(CloverBuildWrapper.java:122)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:80)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:36)
      at java.util.Arrays.mergeSort(Arrays.java:1157)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1168)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.sort(Arrays.java:1092)
      at java.util.Collections.sort(Collections.java:134)
      17-May-2011 20:15:20 hudson.model.Hudson$5 onAttained
      INFO: Started all plugins
      17-May-2011 20:15:20 hudson.model.Hudson$5 onAttained
      INFO: Augmented all extensions
      [Winstone 2011/05/17 20:19:51] - Untrapped Error in Servlet

      Looking at the log above, it seems like it's the git plugin. But it happens at other places, too for example this noon, the error looked like this:

      INFO: Started all plugins
      17-May-2011 12:53:11 hudson.model.Hudson$5 onAttained
      INFO: Augmented all extensions
      17-May-2011 12:57:38 hudson.model.Hudson$5 onTaskFailed
      SEVERE: Failed NullIdDescriptorMonitor.verifyId
      java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:114)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:174)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at hudson.model.Hudson$4.runTask(Hudson.java:735)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:636)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:616)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:110)
      ... 8 more
      Caused by: java.lang.StackOverflowError
      at java.lang.ClassLoader.findBootstrapClass(Native Method)
      at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:900)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:316)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:314)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at winstone.classLoader.WebappClassLoader.loadClass(WebappClassLoader.java:55)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:314)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:314)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
      at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
      at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at hudson.ClassicPluginStrategy$DependencyClassLoader.findClass(ClassicPluginStrategy.java:426)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:314)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
      at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:641)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:204)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:277)
      at hudson.ExtensionList.load(ExtensionList.java:237)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:208)
      at hudson.ExtensionList.iterator(ExtensionList.java:115)
      at hudson.model.Hudson.getDescriptorByType(Hudson.java:1003)
      at hudson.tasks.Mailer.descriptor(Mailer.java:143)
      at hudson.model.Hudson.getRootUrl(Hudson.java:1806)
      at hudson.plugins.clover.CloverBuildWrapper$DescriptorImpl.getDisplayName(CloverBuildWrapper.java:122)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:80)
      at hudson.ExtensionComponent.compareTo(ExtensionComponent.java:36)
      at java.util.Arrays.mergeSort(Arrays.java:1157)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1168)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.mergeSort(Arrays.java:1169)
      at java.util.Arrays.sort(Arrays.java:1092)

      etc ...

      If you need anything else, just ask.

        Attachments

          Activity

          gennadiylitvinyuk Gennadiy Litvinyuk added a comment -

          I have the same Problem. (Debian 6.0)

          Have to downgrade to 1.4.11

          pnyheim Paul Nyheim added a comment -

          We get this one as well, and downgrade works for us too.
          Looking at the stacktrace, the CloverBuildWrapper seems to be recurring a lot of times, so maybe the clover plugin is a place to start looking for trouble.?

          erka Roman Dmytrenko added a comment - - edited

          I had the same problem. I downgraded to 1.411 and updated all my plugins. Then I upgrated my jenkins to 1.412 and it is running well now. I hope you will run it too.

          tvlooy Tom Van Looy added a comment - - edited

          Updating the plugins helped. I am now running 1.412. Thanks!
          edit: we are also running without the clover plugin at the moment (will reinstall clover later)

          sogabe sogabe added a comment -

          fixed in Clover Plugin 4.0.1


            People

            • Assignee:
              Unassigned
              Reporter:
              tvlooy Tom Van Looy
            • Votes:
              3 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: