Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10059

NoClassDefFoundError: org/apache/tools/ant/types/selectors/TokenizedPath after upgrading to 1.417

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 1.417
      z/Linux (s390x) 64bit
    • Similar Issues:

      Description

      After upgrading to Jenkins 1.417 (from 1.416) the following error appeared in the console output while executing a job on our z/Linux build slave.

      ERROR: Failed to archive test reports
      hudson.util.IOException2: remote file operation failed: /home/*****/jenkins/workspace/****** at hudson.remoting.Channel@eae9cc:Runtime_zLinux_Slave
      	at hudson.FilePath.act(FilePath.java:754)
      	at hudson.FilePath.act(FilePath.java:740)
      	at hudson.tasks.junit.JUnitParser.parse(JUnitParser.java:83)
      	at hudson.tasks.junit.JUnitResultArchiver.parse(JUnitResultArchiver.java:123)
      	at hudson.tasks.junit.JUnitResultArchiver.perform(JUnitResultArchiver.java:135)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:664)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:639)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:617)
      	at hudson.model.Build$RunnerImpl.post2(Build.java:161)
      	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:586)
      	at hudson.model.Run.run(Run.java:1400)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:146)
      Caused by: java.io.IOException: Remote call on Runtime_zLinux_Slave failed
      	at hudson.remoting.Channel.call(Channel.java:676)
      	at hudson.FilePath.act(FilePath.java:747)
      	... 14 more
      Caused by: java.lang.NoClassDefFoundError: org/apache/tools/ant/types/selectors/TokenizedPath
      	at org.apache.tools.ant.DirectoryScanner.scan(DirectoryScanner.java:869)
      	at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:490)
      	at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:451)
      	at hudson.tasks.junit.JUnitParser$ParseResultCallable.invoke(JUnitParser.java:105)
      	at hudson.tasks.junit.JUnitParser$ParseResultCallable.invoke(JUnitParser.java:87)
      	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1980)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:283)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:452)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:314)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:149)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:897)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:919)
      	at java.lang.Thread.run(Thread.java:736)
      

      The JRE used on the build slave is "IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux s390x-64".

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Does this issue appear in newest versions.
            It could be JVM-specific (JENKINS-23176)

            oleg_nenashev Oleg Nenashev added a comment -

            Too old, no recent reports


              People

              • Assignee:
                Unassigned
                Reporter:
                fredg Fred G
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: