Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23176

IBM J9 seems to be unsupported on Jenkins

    Details

    • Similar Issues:

      Description

      It's just a master issue for all compatibility issues between IBM J9 and Jenkins.
      Most probably, the complete fix requires multiple changes in various places.

        Attachments

          Issue Links

            Activity

            Hide
            bluejaguar John Tal added a comment - - edited

            Any guestimate/ETA on a fix for this? There are specific java builds we need to do on IBM JRE/J9 and our only option is to stay on an older version of Hudson.

            Show
            bluejaguar John Tal added a comment - - edited Any guestimate/ETA on a fix for this? There are specific java builds we need to do on IBM JRE/J9 and our only option is to stay on an older version of Hudson.
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Unfortunately, nobody has took the issue, hence there's no ETAs at all.

            Show
            oleg_nenashev Oleg Nenashev added a comment - Unfortunately, nobody has took the issue, hence there's no ETAs at all.
            Hide
            danielbeck Daniel Beck added a comment -

            Oleg: IMO this meta issue is a bad idea. We're likely to only get comments like John's here.


            John: The Jenkins process' JVM and the javac process are independent, so you should be able to run Jenkins with Oracle JDK/JRE, and build with J9 (except with Maven job type, maybe). Also, most or all of the issues seem to only apply to the Jenkins master. Try running the master on another JDK, then add a slave running J9. Also, possible solutions are best discussed on the jenkinsci-users mailing list.

            Show
            danielbeck Daniel Beck added a comment - Oleg: IMO this meta issue is a bad idea. We're likely to only get comments like John's here. John: The Jenkins process' JVM and the javac process are independent, so you should be able to run Jenkins with Oracle JDK/JRE, and build with J9 (except with Maven job type, maybe). Also, most or all of the issues seem to only apply to the Jenkins master. Try running the master on another JDK, then add a slave running J9. Also, possible solutions are best discussed on the jenkinsci-users mailing list.
            Hide
            bluejaguar John Tal added a comment -

            Hi Daniel, thanks for the hint/reminder about running specific jobs to specific JDK. We are now able to build what we need to under IBM J9. The criticality of this issue is lessened for us. And now others who come to this issue will also have a workaround.

            Show
            bluejaguar John Tal added a comment - Hi Daniel, thanks for the hint/reminder about running specific jobs to specific JDK. We are now able to build what we need to under IBM J9. The criticality of this issue is lessened for us. And now others who come to this issue will also have a workaround.
            Hide
            danielbeck Daniel Beck added a comment -

            Two more issues that may be related to IBM J9.

            Show
            danielbeck Daniel Beck added a comment - Two more issues that may be related to IBM J9.

              People

              • Assignee:
                Unassigned
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                3 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: