Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12113

Maven - java.io.IOException: error=2, No such file or directory if in SVN configuration parameters used in Local module directory section

    Details

    • Similar Issues:

      Description

      Maven is unable to work if in Subversion configuration parameters are used in Local module directory section.
      As you can see in svn_maven_issue_01.PNG Ive specified predefined variable in Local module directory section. And when I run it - Maven failed (svn_maven_issue_02.PNG) with java.io.IOException.

        Attachments

          Issue Links

            Activity

            pxantom Oleksandr Popov created issue -
            pxantom Oleksandr Popov made changes -
            Field Original Value New Value
            Priority Critical [ 2 ] Blocker [ 1 ]
            pxantom Oleksandr Popov added a comment -

            Any update on this?

            pxantom Oleksandr Popov made changes -
            Description Maven is unable to work if in Subversion configuration parameters used in Local module directory section.
            As you can see in svn_maven_issue_01.PNG Ive specified predefined variable in Local module directory section. And when I run it - Maven failed (svn_maven_issue_02.PNG) with java.io.IOException.
            Maven is unable to work if in Subversion configuration parameters are used in Local module directory section.
            As you can see in svn_maven_issue_01.PNG Ive specified predefined variable in Local module directory section. And when I run it - Maven failed (svn_maven_issue_02.PNG) with java.io.IOException.
            kutzi kutzi added a comment -

            This sounds suspiciously like a dup of JENKINS-11798 - which you have created, too ...

            kutzi kutzi made changes -
            Link This issue duplicates JENKINS-11798 [ JENKINS-11798 ]
            kutzi kutzi added a comment -

            Another question is, why do you expect the Maven plugin to work correctly, if the subversion plugin is already not able to resolve the $Branch parameter?

            kutzi kutzi made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            pxantom Oleksandr Popov added a comment -

            @kutzi Subversion plugin has resolved it correctly. The only this is exeption which is given by Maven plugin. It tries to execute mvn command from directory with includes $Branch variable. But it does not resolves variable before execution. That is the reason.

            pxantom Oleksandr Popov added a comment - - edited

            @kutzi I have closed JENKINS-11798 ticket cause it is not actual (Subversion plugin is not the root of the issue). This ticket actually is not duplicate but provides deeper investigation of the same issue

            pxantom Oleksandr Popov made changes -
            Resolution Duplicate [ 3 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            pxantom Oleksandr Popov made changes -
            Assignee kutzi [ kutzi ]
            kutzi kutzi added a comment -

            Okay, thanks for the added info and sorry for closing this prematurely.
            I can look at it, but cannot make any promises on the time frame.

            kutzi kutzi made changes -
            Link This issue duplicates JENKINS-11798 [ JENKINS-11798 ]
            kutzi kutzi made changes -
            Link This issue is related to JENKINS-11798 [ JENKINS-11798 ]
            pxantom Oleksandr Popov added a comment -

            Any update on this?

            pxantom Oleksandr Popov added a comment -

            The same happens to Ant:
            08:03:03 FATAL: Unable to find build script at /*******/*/Jenkins/workspace/******/$Branch/*****/Install/ant/build.xml
            @kutzi: please advice!

            kutzi kutzi added a comment -

            Seemingly, variable resolution was neither implemented in the 'local module' part of subversion-plugin nor in ant build steps.

            BTW: where did you define the variable?

            PS: I don't consider this being a bug, but rather a missing feature

            pxantom Oleksandr Popov added a comment -

            Hi, Ive implemented it in job parameters (checked both String and Choise). Also tried Global parameter - issue the same. It is quite critical for us because we need to support different branches at the same time and the only solution for us now is to copy all projects and predefine all variables.

            pxantom Oleksandr Popov added a comment - - edited

            I think that issue is in maven and ant plugins which should resolve variables.
            And the issues is still present on 1.447 Jenkins release

            kutzi kutzi added a comment -

            Erm, sorry. Yes I meant to write "maven and ant", but did mistakenly write "subversion"

            pxantom Oleksandr Popov added a comment - - edited

            Could this issue fixed soon? I do not think that this is to complicated issue...

            pxantom Oleksandr Popov made changes -
            Environment Jenkins 1.443
            Subversion Plugin 1.37
            Maven Integration Plugin 1.443
            Jenkins 1.447
            Subversion Plugin 1.37
            Maven Integration Plugin 1.447
            Ant 1.1
            kutzi kutzi added a comment -

            Shouldn't be too complicated, but as I've said I cannot promise on any timeframe.

            Did you ask on the users list - maybe someone had a similar requirement and knows of a workaround?

            pxantom Oleksandr Popov added a comment -

            Unfortunately I don't know what users list is... But I do not think that there is some workaround on this issue.

            pxantom Oleksandr Popov added a comment - - edited

            @kutzi - I dont thing there is workaround for this issue. Maybe you can advice where to look so our developers may try to fix this?

            pxantom Oleksandr Popov made changes -
            Environment Jenkins 1.447
            Subversion Plugin 1.37
            Maven Integration Plugin 1.447
            Ant 1.1
            Jenkins 1.448
            Subversion Plugin 1.37
            Maven Integration Plugin 1.448
            Ant 1.1
            Component/s parameters [ 15594 ]
            peter_schuetze peter_schuetze added a comment -

            Hi Oleksandr,

            Don't know why you actually need the branch name in the local module path. Since you are only working with one branch at a time, you can use a fixed name for your local path or no path at all. This of course means that you should use the "always check out fresh copy", but I use that approach anyway. It gives me a better feeling about using the right version of code.

            pxantom Oleksandr Popov added a comment -

            @peter_schuetze:
            Hi Peter,
            The thing is that I wanted to use single job for building from different branches (according our SCM approach we have a lot of trunks and release brunches). Therefore I'd liked to use a parameter in "Local module directory" section. Our branched weight a lot sometime it takes up to 5 minutes to do checkout.
            And after all I suppose that this is bug. I believe that the root of the issue is compatibility between those (Maven, Ant, Parametrized) plugins.

            pxantom Oleksandr Popov added a comment -

            @kutzi - Any updates or estimates?

            kutzi kutzi made changes -
            Component/s maven2 [ 15487 ]
            kutzi kutzi added a comment -

            This is arguably no 'Blocker' issue. Blocker is if you can't use something at all - for this issue there are some obvious workarounds.

            kutzi kutzi made changes -
            Priority Blocker [ 1 ] Major [ 3 ]
            kutzi kutzi added a comment -

            Looks like this can be fixed quite easily by overriding the newer getModuleRoot(s) methods .

            Could you please try the attached updated subversion plugin if it fixes your issue?

            kutzi kutzi made changes -
            Attachment subversion.hpi [ 21480 ]
            pxantom Oleksandr Popov added a comment - - edited

            Yes! Looks like that fixes the issue...

            pxantom Oleksandr Popov added a comment -

            One little question: when it will be released?

            kutzi kutzi added a comment -

            Still need to write some unit tests and ask other devs if it's okay to do a release now.
            Hope to have it this weekend or beginning of next week.

            pxantom Oleksandr Popov added a comment -

            Great news! Hope so

            dogfood dogfood added a comment -

            Integrated in plugins_subversion #146
            [FIXED JENKINS-12113] local module directory is not expanded with EnvVars (Revision 40279)

            Result = SUCCESS
            kutzi :
            Files :

            • /trunk/hudson/plugins/subversion/src/main/java/hudson/scm/SubversionSCM.java
            • /trunk/hudson/plugins/subversion/src/test/java/hudson/scm/SubversionSCMUnitTest.java
            kutzi kutzi added a comment -

            Will be in subversion-plugin 1.38

            kutzi kutzi made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kutzi
            Path:
            src/main/java/hudson/scm/SubversionSCM.java
            src/test/java/hudson/scm/SubversionSCMUnitTest.java
            http://jenkins-ci.org/commit/subversion-plugin/c96f849400174ca476650f2e1b13cd3993027c3b
            Log:
            [FIXED JENKINS-12113] local module directory is not expanded with EnvVars

            pxantom Oleksandr Popov added a comment -

            Thanks for you help!

            pxantom Oleksandr Popov made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-20344 [ JENKINS-20344 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s parameters [ 15594 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s maven2 [ 15487 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 142434 ] JNJira + In-Review [ 205547 ]

              People

              • Assignee:
                kutzi kutzi
                Reporter:
                pxantom Oleksandr Popov
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: