Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13238

Loading All Build History Fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      linux, jenkins 1.456
    • Similar Issues:

      Description

      seems after the update from 1.455 to 1.456 causes an issue where pressing 'More' to expand the job Build History now fails with a 404.

      Calling the build history directly also causes the 404, eg.
      http://openocd.zylin.com/jenkins/job/openocd/buildHistory/all/

      For info rolling back to 1.455 cures the problem.
      tested 1.457 and issue still present.

      jenkins own server also shows the issue:
      http://ci.jenkins-ci.org/view/All/job/jenkins_main_trunk/buildHistory/all/

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Seiji Sogabe
            Path:
            core/src/main/resources/hudson/widgets/HistoryWidget/index.jelly
            http://jenkins-ci.org/commit/jenkins/a45ecf45ee8571aae7a0273784971afeeefb6e3c
            Log:
            [FIXED JENKINS-13238] Loading All Build History Fails

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #1625
            [FIXED JENKINS-13238] Loading All Build History Fails (Revision a45ecf45ee8571aae7a0273784971afeeefb6e3c)

            Result = SUCCESS
            Seiji Sogabe : a45ecf45ee8571aae7a0273784971afeeefb6e3c
            Files :

            • core/src/main/resources/hudson/widgets/HistoryWidget/index.jelly
            jakub Jakub Czaplicki added a comment -

            The issue is still present 1.458

            ohtake_tomohiro OHTAKE Tomohiro added a comment -

            The fix will be available in 1.459.
            See http://jenkins-ci.org/changelog and click "Upcoming changes".

            Or, you can use an RC http://jenkins-ci.org/rc

            dogfood dogfood added a comment -

            Integrated in jenkins_ui-changes_branch #21
            [FIXED JENKINS-13238] Loading All Build History Fails (Revision a45ecf45ee8571aae7a0273784971afeeefb6e3c)

            Result = SUCCESS
            Seiji Sogabe : a45ecf45ee8571aae7a0273784971afeeefb6e3c
            Files :

            • core/src/main/resources/hudson/widgets/HistoryWidget/index.jelly
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Seiji Sogabe
            Path:
            core/src/main/resources/hudson/widgets/HistoryWidget/index.jelly
            http://jenkins-ci.org/commit/jenkins/007cd042b59a07f2b3243131b6494ef7a97d7b3e
            Log:
            [FIXED JENKINS-13238] Loading All Build History Fails
            (cherry picked from commit a45ecf45ee8571aae7a0273784971afeeefb6e3c)


              People

              • Assignee:
                sogabe sogabe
                Reporter:
                ntfreak Spencer Oliver
              • Votes:
                3 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: