Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15301

HTML Publisher failure: Failed to extract directory from slave

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: htmlpublisher-plugin
    • Environment:
      Slave:
      - HP ProLiant DL380 G5
      - uname -r: 2.6.32-5-amd64
      - java -version: java version "1.6.0_18", OpenJDK Runtime Environment (IcedTea6 1.8.13) (6b18-1.8.13-0+squeeze2), OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
    • Similar Issues:

      Description

      Hi,

      in my jenkins-setup i am using a master/slave system. When a Job is executed, everything works fine until htmlpublisher is supposed to archive one HTML report. Usually the execution hangs, sometimes an exception is reported[1]

      As you can see, htmlpublisher tries to extract /home/jenkins-slave9/.../code-browser from slave, this fails.

      Problem occurred in Jenkins v. 1.456, I tried some versions in between, also the current v. 1.483 is affected.

      [1]

      [htmlpublisher] Archiving HTML reports...
      [htmlpublisher] Archiving at BUILD level /home/jenkins-slave9/workspace/wkw_cssjs/unitTesting/build/code-browser to /var/wkw/jenkins/jobs/wkw_cssjs/builds/2012-09-25_10-30-44/htmlreports/Code_Browser
      FATAL: HTML Publisher failure
      hudson.util.IOException2: hudson.util.IOException2: Failed to extract /home/jenkins-slave9/workspace/wkw_cssjs/unitTesting/build/code-browser/**/*
      	at hudson.FilePath.readFromTar(FilePath.java:1936)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:1848)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:1756)
      	at htmlpublisher.HtmlPublisher.perform(HtmlPublisher.java:212)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:717)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:692)
      	at hudson.model.Build$BuildExecution.post2(Build.java:183)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:639)
      	at hudson.model.Run.execute(Run.java:1527)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:236)
      Caused by: java.io.IOException
      	at hudson.remoting.FastPipedInputStream.read(FastPipedInputStream.java:175)
      	at hudson.util.HeadBufferingStream.read(HeadBufferingStream.java:61)
      	at java.util.zip.InflaterInputStream.fill(InflaterInputStream.java:221)
      	at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:141)
      	at java.util.zip.GZIPInputStream.read(GZIPInputStream.java:92)
      	at org.apache.tools.tar.TarBuffer.readBlock(TarBuffer.java:257)
      	at org.apache.tools.tar.TarBuffer.readRecord(TarBuffer.java:223)
      	at hudson.org.apache.tools.tar.TarInputStream.read(TarInputStream.java:345)
      	at java.io.FilterInputStream.read(FilterInputStream.java:90)
      	at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1025)
      	at org.apache.commons.io.IOUtils.copy(IOUtils.java:999)
      	at hudson.util.IOUtils.copy(IOUtils.java:37)
      	at hudson.FilePath.readFromTar(FilePath.java:1926)
      	... 12 more
      
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:1855)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:1756)
      	at htmlpublisher.HtmlPublisher.perform(HtmlPublisher.java:212)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:717)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:692)
      	at hudson.model.Build$BuildExecution.post2(Build.java:183)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:639)
      	at hudson.model.Run.execute(Run.java:1527)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:236)
      Caused by: java.util.concurrent.ExecutionException: hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.Request$1.get(Request.java:278)
      	at hudson.remoting.Request$1.get(Request.java:210)
      	at hudson.remoting.FutureAdapter.get(FutureAdapter.java:59)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:1851)
      	... 11 more
      Caused by: hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.Request.abort(Request.java:299)
      	at hudson.remoting.Channel.terminate(Channel.java:724)
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      Caused by: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
      Caused by: java.io.EOFException
      	at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2553)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1296)
      	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
      	at hudson.remoting.Command.readFrom(Command.java:90)
      	at hudson.remoting.ClassicCommandTransport.read(ClassicCommandTransport.java:59)
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
      

        Attachments

          Issue Links

            Activity

            schultemarkus Markus Schulte added a comment -

            Same problem, but in this case (#15301) there is no symlink present.

            jglick Jesse Glick added a comment -

            Not clearly related to JENKINS-13614.

            schultemarkus Markus Schulte added a comment -

            Problem still exists in Jenkins 1.492

            jarmenia John Armenia added a comment -

            Problem still exists in 1.544

            wesleyarchbell Wesley Archbell added a comment -

            I have this problem on version 1.532.3. Its happening on remote suse slaves.. Same behaviour, it gets to last step; htmlpublisher hangs; when i kill job it throws the above exception. Odd thing is its only happening to about half the suse boxes.. the others are fine and they have the same setup.

            Anyone know when this will be fixed?

            mcrooney mcrooney added a comment -

            Unfortunately, while I wrote this plugin, I'm not familiar with remote slaves or what is causing this. If anyone is able to take a look it at and submit a pull request at https://github.com/jenkinsci/htmlpublisher-plugin, it would be greatly appreciated!

            r2b2_nz Richard Bywater added a comment -

            Hi - this issue has been around and not touched for a year or more. In an effort to try and focus on issues which are still present, I am resolving these issues for now.

            If you feel that the issue is still present, please feel free to re-open / comment. I'll be closing off any issues that haven't had any re-opening or comments by the end of the month.

            Thanks for reporting these issues - hopefully you are still using HTML Publisher and its working for you but, if not, let me know so that I can focus on issues that are causing you problems today


              People

              • Assignee:
                r2b2_nz Richard Bywater
                Reporter:
                schultemarkus Markus Schulte
              • Votes:
                6 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: