Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16018

Not all builds show in the build history dashboard on job

    Details

    • Similar Issues:

      Description

      All of the builds that are present on disk do not show up in the 'Build History' in the latest jenkins.

      I noticed the problem happening where only the last build or last couple builds would show up with the newest version (1.492). I then decided to go back to the latest stable version (1.480.1) to see if that solved the problem. The problem again occurred. I had only build 11 showing for my job, and I rolled back all the way to 1.455, a known stable version. All 11 builds showed back up in the build history.

        Attachments

          Issue Links

            Activity

            andy0815 Andreas W added a comment - - edited

            This really deserves to be a blocker, also happens for me in Jenkins 1.570 and 1.571, also with Windows Server 2008 R2. Builds are on disk but symbolic links disappear.

            danielbeck Daniel Beck added a comment -

            This issue is a complete joke and should be closed, as comments contradict the original issue description and each other. It looks like several independent issues with similar symptoms.

            andy0815 Andreas W added a comment -

            Sorry but i can't laugh about this, there are dozens of issues similar to this, all with the symptom of disappearing builds. I really cannot understand why. I could enter a new bug. I place my bets, that this will also get closed because its similar to one of the other similar bugs fixed. The disappearance of build of builds seems to be so common, how should i know which cause my observed bug has.

            danielbeck Daniel Beck added a comment -

            Andreas W: What this report is missing is information that can be used to investigate the problem. If I tried to determine the cause, I would not have any chance to do so, because what little information there is, is inconsistent. I cannot even be sure that all of the preceding comments are about either the page that's called "Build History" and contains a timeline and table, or the list of builds in the sidepanel of a single job.

            Please consider filing a new bug against core. Provide as much information as you can: Jenkins logs (also create a logger for jenkins.model.PeepholePermalink at level FINE); list of plugins from /systemInfo; install Support Core plugin and attach a support bundle; describe which jobs (all? some? which?) are affected how often, does it correlate with other events in Jenkins?; what happens when you reload from disk or restart Jenkins. Maybe even add screenshots of disk contents and what the Jenkins UI shows instead, and provide a heap dump. If you want to get fancy, do some investigation yourself: Can you set up a new Jenkins instance and configure it in a way that the issue occurs there as well? You likely are a software developer or an ops guy, so provide all the information you'd want to see in an issue report!

            (FWIW that goes for all readers experiencing this problem on a current version of Jenkins!)

            I'm not saying none of those will get closed as duplicate of another, possibly still unresolved issue. But this should drastically increase the chance of a) someone investigating the problem b) actually finding a solution.

            danielbeck Daniel Beck added a comment -

            Since nobody watching this provided additional information since I posted the previous comment, I'm resolving this as cannot reproduce.

            If you experience this issue on a Jenkins release no older than eight weeks (LTS or latest&greatest), please file a new bug against core and include ALL the information asked for in the preceding comment.

            In the preceding comment I also explain why this issue description and the comments are not useful in getting this issue resolved. In essence, too little real information is provided here, and comments seem to contradict, indicating different causes. Newly filed issues won't have this problem.

            If you're using a version older than eight weeks, and cannot reproduce the problem (or did not try to do so) on a current Jenkins version, please refrain from filing a new issue. Many issues in Jenkins get fixed during normal development and it's a waste of time trying to investigate long resolved issues.


              People

              • Assignee:
                Unassigned
                Reporter:
                w25r William Lichtenberger
              • Votes:
                23 Vote for this issue
                Watchers:
                36 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: