Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15156

Builds disappear from build history after completion

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 1.477.2
      Master and Slaves Windows Server 2008 r2
      (Also on Jenkins 1.488 Windows Server 2008)

      Description

      We have recently noticed builds disappearing from the "Build History" listing on the project page. Developer was watching a build, waiting for it to complete and said it disappeared after it finished. Nothing was noted in any of the logs concerning that build.
      The data was still present on the disk and doing a reload from disk brought the build back. We have other automated jobs that deploy these builds based on build number, so it is pretty big issue in our environment.
      We are not able to reproduce at this point, but I still wanted to document what was happening.
      I have seen other JIRA issues that look similar, but in those jobs were disappearing after a restart, or upgrade. That is not the case for us. The build disappears after completion, success or failure.

        Issue Links

          Activity

          kveretennicov Constantin Veretennicov added a comment -

          Similar symptoms of "disappearing builds", but different root cause.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Jesse Glick
          Path:
          test/src/test/groovy/hudson/model/AbstractProjectTest.groovy
          http://jenkins-ci.org/commit/jenkins/389a565de417170f586830ee9fa7a7ec9749fc68
          Log:
          JENKINS-10615 AbstractProjectTest.testWorkspaceLock frequently fails on jenkins.ci due to InterruptedException in HudsonTestCase.setUp.
          Possibly because it is sorted after JENKINS-15156 testGetBuildAfterGC and the test suite times out.

          (cherry picked from commit 85e9e126773c0bb20a8529a2e6591dde17d7e209)

          ashah Andy Shah added a comment - - edited

          Recently upgraded from Jenkins 1.540 to latest release 1.605, After upgrade noticed build history for all the Jenkins jobs were gone. I currently have close to 350 jobs and losing history is really pain. Had to downgrade to 1.540 to restore the environment.

          Update: Tried "Reload Configuration" option but no luck.

          danielbeck Daniel Beck added a comment -

          After upgrade noticed build history for all the Jenkins jobs were gone

          Completely unrelated issue.

          novaind ang chang added a comment -

          Hi,
          I am facing the same problem on Jenkins 1.555 on windows. Sometime build history item will disappear when running and leave the job unfinished.
          So I am wondering this bug is fixed on which version? Can I avoid this problem by upgrading to new version?


            People

            • Assignee:
              Unassigned
              Reporter:
              bbonn bbonn
            • Votes:
              61 Vote for this issue
              Watchers:
              116 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: