Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19453

Slave launcher fails after NoClassDefFoundError: Could not initialize class jenkins.model.Jenkins$MasterComputer

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      Core versions: Jenkins-1.509.2, Jenkins-1.509.3, Jenkins-1.509.4-RC
      Master: Windows server 2007 SP1; RHEL6
      Slave: Linux Mint 64 bits; Windows 7 (JNLP)
    • Similar Issues:

      Description

      I am able to start slave.jar via ssh or via jnlp.
      The log of the connection shows that the node is correctly started.
      In a project, I have 2 main parts:

      • a svn checkout
      • a shell command to start cmake + compilation.

      If I launch my build, it hangs. Then, I disabled the svn checkout and leave only the shell command with a "echo hello".
      If I start the build, it hangs with the following error message:

      Started by user anonymous
      [EnvInject] - Loading node environment variables.
      Building remotely on slave_linux_64 in workspace /home/crystal/jenkins/workspace/TESTLinux
      FATAL: command execution failed
      java.io.IOException: Remote call on slave_linux_64 failed
      at hudson.remoting.Channel.call(Channel.java:723)
      at hudson.Launcher$RemoteLauncher.launch(Launcher.java:862)
      at hudson.Launcher$ProcStarter.start(Launcher.java:353)
      at hudson.Launcher$ProcStarter.join(Launcher.java:360)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:91)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:60)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      at hudson.model.Build$BuildExecution.build(Build.java:199)
      at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:586)
      at hudson.model.Run.execute(Run.java:1603)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:247)
      Caused by: java.lang.NoClassDefFoundError: Could not initialize class jenkins.model.Jenkins$MasterComputer
      at hudson.Launcher$LocalLauncher.<init>(Launcher.java:755)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:991)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:965)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at hudson.remoting.Engine$1$1.run(Engine.java:63)
      at java.lang.Thread.run(Thread.java:724)
      Build step 'Execute shell' marked build as failure
      Finished: FAILURE

      When I looked at the jenkins directory I configured on the slave, all the required jar are present, the workspace directory is present and the build directory is correctly created by the jenkins master. But nothing in this directory.

        Attachments

          Issue Links

            Activity

            vikulin Vadym Vikulin added a comment - - edited

            Reproduced on 1.585:

            Started by user Vadym Vikulin
            [EnvInject] - Loading node environment variables.
            Building remotely on win7-node-01 (Win7) in workspace C:\work\workspace\Win7-ED
            [EnvInject] - Executing scripts and injecting environment variables after the SCM step.
            [EnvInject] - Injecting as environment variables the properties content
            CLASSPATH=C:\work\edtest\common\libs*:C:\work\edtest\common;C:\work\edtest\all\edJava;C:\work\edtest\all\edNative/libs/*

            [EnvInject] - Variables injected successfully.
            [Win7-ED] $ cmd /c call C:\Users\VADYMV~1\AppData\Local\Temp\hudson142281969965340690.bat
            FATAL: command execution failed
            java.io.IOException: Remote call on win7-node-01 failed
            at hudson.remoting.Channel.call(Channel.java:751)
            at hudson.Launcher$RemoteLauncher.launch(Launcher.java:915)
            at hudson.Launcher$ProcStarter.start(Launcher.java:380)
            at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:97)
            at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:66)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
            at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
            at hudson.model.Build$BuildExecution.build(Build.java:199)
            at hudson.model.Build$BuildExecution.doRun(Build.java:160)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
            at hudson.model.Run.execute(Run.java:1759)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:89)
            at hudson.model.Executor.run(Executor.java:240)
            Caused by: java.lang.NoClassDefFoundError: Could not initialize class hudson.Util
            at hudson.EnvVars$OverrideOrderCalculator.scan(EnvVars.java:281)
            at hudson.EnvVars$OverrideOrderCalculator.<init>(EnvVars.java:223)
            at hudson.EnvVars.overrideExpandingAll(EnvVars.java:329)
            at hudson.Launcher.inherit(Launcher.java:1227)
            at hudson.Launcher.inherit(Launcher.java:1219)
            at hudson.Launcher.access$200(Launcher.java:81)
            at hudson.Launcher$LocalLauncher.launch(Launcher.java:795)
            at hudson.Launcher$ProcStarter.start(Launcher.java:380)
            at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1135)
            at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1100)
            at hudson.remoting.UserRequest.perform(UserRequest.java:118)
            at hudson.remoting.UserRequest.perform(UserRequest.java:48)
            at hudson.remoting.Request$2.run(Request.java:328)
            at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
            at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
            at java.util.concurrent.FutureTask.run(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at hudson.remoting.Engine$1$1.run(Engine.java:63)
            at java.lang.Thread.run(Unknown Source)
            FATAL: Unable to delete script file C:\Users\VADYMV~1\AppData\Local\Temp\hudson142281969965340690.bat
            java.io.IOException: remote file operation failed: C:\Users\VADYMV~1\AppData\Local\Temp\hudson142281969965340690.bat at hudson.remoting.Channel@5dc020b1:win7-node-01
            at hudson.FilePath.act(FilePath.java:914)
            at hudson.FilePath.act(FilePath.java:896)
            at hudson.FilePath.delete(FilePath.java:1321)
            at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:106)
            at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:66)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
            at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
            at hudson.model.Build$BuildExecution.build(Build.java:199)
            at hudson.model.Build$BuildExecution.doRun(Build.java:160)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
            at hudson.model.Run.execute(Run.java:1759)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:89)
            at hudson.model.Executor.run(Executor.java:240)
            Caused by: java.io.IOException: Remote call on win7-node-01 failed
            at hudson.remoting.Channel.call(Channel.java:751)
            at hudson.FilePath.act(FilePath.java:907)
            ... 13 more

            jglick Jesse Glick added a comment -

            Vadym Vikulin your problem is probably distinct and should be filed separately. Look for an earlier message explaining why hudson.Util could not be loaded.

            jeebitesh Jeebitesh Kalantri added a comment -

            Solution :- If you are running slave on windows VM\Server with 64 bit OS
            Make sure of few things
            1) You should have 32 bit JRE Installed
            2) It should be default JRE - you go to configure Java and change the settings if you have 64 bit and 32 bit both change the default to 32 bit path.
            3) Restart the Slave and that's it, Vola

            svchipiga Sergey Chipiga added a comment - - edited

            Hi!
            I have still this problem (Jenkins ver. 1.580.2):
            <code>
            FATAL: Remote call on win7-home-premium-x86-ru-1-f8e failed
            20:33:18 java.io.IOException: Remote call on win7-home-premium-x86-ru-1-f8e failed
            20:33:18 at hudson.remoting.Channel.call(Channel.java:760)
            20:33:18 at hudson.Launcher$RemoteLauncher.kill(Launcher.java:941)
            20:33:18 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:556)
            20:33:18 at hudson.model.Run.execute(Run.java:1745)
            20:33:18 at hudson.matrix.MatrixRun.run(MatrixRun.java:146)
            20:33:18 at hudson.model.ResourceController.execute(ResourceController.java:89)
            20:33:18 at hudson.model.Executor.run(Executor.java:240)
            20:33:18 Caused by: java.lang.Error: Unable to load resource winp.dll
            20:33:18 at hudson.remoting.RemoteClassLoader.findResource(RemoteClassLoader.java:381)
            20:33:18 at java.lang.ClassLoader.getResource(Unknown Source)
            20:33:18 at org.jvnet.winp.Native.load(Native.java:85)
            20:33:18 at org.jvnet.winp.Native.<clinit>(Native.java:56)
            20:33:18 at org.jvnet.winp.WinProcess.enableDebugPrivilege(WinProcess.java:212)
            20:33:18 at hudson.util.ProcessTree$Windows.<clinit>(ProcessTree.java:469)
            20:33:18 at hudson.util.ProcessTree.get(ProcessTree.java:328)
            20:33:18 at hudson.Launcher$RemoteLauncher$KillTask.call(Launcher.java:953)
            20:33:18 at hudson.Launcher$RemoteLauncher$KillTask.call(Launcher.java:944)
            20:33:18 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
            20:33:18 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
            20:33:18 at hudson.remoting.Request$2.run(Request.java:324)
            20:33:18 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
            20:33:18 at java.util.concurrent.FutureTask.run(Unknown Source)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            20:33:18 at hudson.remoting.Engine$1$1.run(Engine.java:63)
            20:33:18 at java.lang.Thread.run(Unknown Source)
            20:33:18 at ......remote call to yabrowser-win7-home-premium-x86-ru-1-f8e(Native Method)
            20:33:18 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
            20:33:18 at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
            20:33:18 at hudson.remoting.Channel.call(Channel.java:752)
            20:33:18 ... 6 more
            20:33:18 Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: Invalid object ID 2 iota=14
            20:33:18 at hudson.remoting.AsyncFutureImpl.get(AsyncFutureImpl.java:75)
            20:33:18 at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55)
            20:33:18 at hudson.remoting.RemoteClassLoader.findResource(RemoteClassLoader.java:373)
            20:33:18 at java.lang.ClassLoader.getResource(Unknown Source)
            20:33:18 at org.jvnet.winp.Native.load(Native.java:85)
            20:33:18 at org.jvnet.winp.Native.<clinit>(Native.java:56)
            20:33:18 at org.jvnet.winp.WinProcess.enableDebugPrivilege(WinProcess.java:212)
            20:33:18 at hudson.util.ProcessTree$Windows.<clinit>(ProcessTree.java:469)
            20:33:18 at hudson.util.ProcessTree.get(ProcessTree.java:328)
            20:33:18 at hudson.Launcher$RemoteLauncher$KillTask.call(Launcher.java:953)
            20:33:18 at hudson.Launcher$RemoteLauncher$KillTask.call(Launcher.java:944)
            20:33:18 at hudson.remoting.UserRequest.perform(UserRequest.java:121)
            20:33:18 at hudson.remoting.UserRequest.perform(UserRequest.java:49)
            20:33:18 at hudson.remoting.Request$2.run(Request.java:324)
            20:33:18 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
            20:33:18 at java.util.concurrent.FutureTask.run(Unknown Source)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            20:33:18 at hudson.remoting.Engine$1$1.run(Engine.java:63)
            20:33:18 at java.lang.Thread.run(Unknown Source)
            20:33:18 Caused by: java.lang.IllegalStateException: Invalid object ID 2 iota=14
            20:33:18 at hudson.remoting.ExportTable.diagnoseInvalidId(ExportTable.java:348)
            20:33:18 at hudson.remoting.ExportTable.get(ExportTable.java:324)
            20:33:18 at hudson.remoting.Channel.getExportedObject(Channel.java:604)
            20:33:18 at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:311)
            20:33:18 at hudson.remoting.Request$2.run(Request.java:324)
            20:33:18 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
            20:33:18 at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
            20:33:18 at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            20:33:18 at java.lang.Thread.run(Thread.java:744)
            20:33:18 at ......remote call to channel(Native Method)
            20:33:18 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
            20:33:18 at hudson.remoting.Request.call(Request.java:171)
            20:33:18 at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:176)
            20:33:18 at com.sun.proxy.$Proxy5.writeJarTo(Unknown Source)
            20:33:18 at hudson.remoting.FileSystemJarCache.retrieve(FileSystemJarCache.java:66)
            20:33:18 at hudson.remoting.JarCacheSupport$1.run(JarCacheSupport.java:62)
            20:33:18 at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
            20:33:18 at java.util.concurrent.FutureTask.run(Unknown Source)
            20:33:18 at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:104)
            20:33:18 ... 1 more
            20:33:18 Caused by: java.lang.Exception: Object was recently deallocated
            20:33:18 #2 (ref.0) : [hudson.remoting.JarLoader]
            20:33:18 Created at Wed Dec 24 20:28:20 MSK 2014
            20:33:18 at hudson.remoting.ExportTable$Entry.<init>(ExportTable.java:93)
            20:33:18 at hudson.remoting.ExportTable.export(ExportTable.java:299)
            20:33:18 at hudson.remoting.Channel.internalExport(Channel.java:600)
            20:33:18 at hudson.remoting.Channel.export(Channel.java:591)
            20:33:18 at hudson.remoting.Channel.<init>(Channel.java:472)
            20:33:18 at hudson.remoting.ChannelBuilder.build(ChannelBuilder.java:280)
            20:33:18 at hudson.remoting.ChannelBuilder.build(ChannelBuilder.java:290)
            20:33:18 at org.jenkinsci.remoting.nio.NioChannelBuilder.build(NioChannelBuilder.java:36)
            20:33:18 at org.jenkinsci.remoting.nio.NioChannelBuilder.build(NioChannelBuilder.java:52)
            20:33:18 at jenkins.slaves.JnlpSlaveAgentProtocol$Handler.jnlpConnect(JnlpSlaveAgentProtocol.java:120)
            20:33:18 at jenkins.slaves.DefaultJnlpSlaveReceiver.handle(DefaultJnlpSlaveReceiver.java:63)
            20:33:18 at jenkins.slaves.JnlpSlaveAgentProtocol2$Handler2.run(JnlpSlaveAgentProtocol2.java:57)
            20:33:18 at jenkins.slaves.JnlpSlaveAgentProtocol2.handle(JnlpSlaveAgentProtocol2.java:31)
            20:33:18 at hudson.TcpSlaveAgentListener$ConnectionHandler.run(TcpSlaveAgentListener.java:156)
            20:33:18 Released at Wed Dec 24 20:28:20 MSK 2014
            20:33:18 at hudson.remoting.ExportTable$Entry.release(ExportTable.java:125)
            20:33:18 at hudson.remoting.ExportTable.unexportByOid(ExportTable.java:376)
            20:33:18 at hudson.remoting.Channel.unexport(Channel.java:612)
            20:33:18 at hudson.remoting.UnexportCommand.execute(UnexportCommand.java:38)
            20:33:18 at hudson.remoting.Channel$2.handle(Channel.java:483)
            20:33:18 at hudson.remoting.AbstractByteArrayCommandTransport$1.handle(AbstractByteArrayCommandTransport.java:61)
            20:33:18 at org.jenkinsci.remoting.nio.NioChannelHub$2.run(NioChannelHub.java:597)
            20:33:18 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
            20:33:18 at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            20:33:18 at hudson.remoting.SingleLaneExecutorService$1.run(SingleLaneExecutorService.java:111)
            20:33:18 at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
            20:33:18 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
            20:33:18 at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            20:33:18 at java.lang.Thread.run(Thread.java:744)
            20:33:18 Caused by: Command hudson.remoting.UnexportCommand@1787906e created at
            20:33:18 at hudson.remoting.Command.<init>(Command.java:67)
            20:33:18 at hudson.remoting.Command.<init>(Command.java:50)
            20:33:18 at hudson.remoting.UnexportCommand.<init>(UnexportCommand.java:33)
            20:33:18 at hudson.remoting.RemoteInvocationHandler.finalize(RemoteInvocationHandler.java:234)
            20:33:18 at java.lang.ref.Finalizer.invokeFinalizeMethod(Native Method)
            20:33:18 at java.lang.ref.Finalizer.runFinalizer(Unknown Source)
            20:33:18 at java.lang.ref.Finalizer.access$100(Unknown Source)
            20:33:18 at java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)
            20:33:18 at hudson.remoting.ExportTable.diagnoseInvalidId(ExportTable.java:341)
            20:33:18 at hudson.remoting.ExportTable.get(ExportTable.java:324)
            20:33:18 at hudson.remoting.Channel.getExportedObject(Channel.java:604)
            20:33:18 at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:311)
            20:33:18 at hudson.remoting.Request$2.run(Request.java:324)
            20:33:18 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
            20:33:18 at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
            20:33:18 at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            20:33:18 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            20:33:18 at java.lang.Thread.run(Thread.java:744)
            20:33:18 Caused by: Released at Wed Dec 24 20:28:20 MSK 2014
            20:33:18 at hudson.remoting.ExportTable$Entry.release(ExportTable.java:125)
            20:33:18 at hudson.remoting.ExportTable.unexportByOid(ExportTable.java:376)
            20:33:18 at hudson.remoting.Channel.unexport(Channel.java:612)
            20:33:18 at hudson.remoting.UnexportCommand.execute(UnexportCommand.java:38)
            20:33:18 at hudson.remoting.Channel$2.handle(Channel.java:483)
            20:33:18 at hudson.remoting.AbstractByteArrayCommandTransport$1.handle(AbstractByteArrayCommandTransport.java:61)
            20:33:18 at org.jenkinsci.remoting.nio.NioChannelHub$2.run(NioChannelHub.java:597)
            20:33:18 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
            20:33:18 at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            20:33:18 at hudson.remoting.SingleLaneExecutorService$1.run(SingleLaneExecutorService.java:111)
            20:33:18 at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
            20:33:18 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
            20:33:18 ... 4 more
            20:33:18 Caused by: Command hudson.remoting.UnexportCommand@1539730b created at
            20:33:18 at hudson.remoting.Command.<init>(Command.java:67)
            20:33:18 at hudson.remoting.Command.<init>(Command.java:50)
            20:33:18 at hudson.remoting.UnexportCommand.<init>(UnexportCommand.java:33)
            20:33:18 at hudson.remoting.RemoteInvocationHandler.finalize(RemoteInvocationHandler.java:234)
            20:33:18 at java.lang.ref.Finalizer.invokeFinalizeMethod(Native Method)
            20:33:18 at java.lang.ref.Finalizer.runFinalizer(Unknown Source)
            20:33:18 at java.lang.ref.Finalizer.access$100(Unknown Source)
            20:33:18 at java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)
            </code>

            Statistically, one from 10 slaves break connection with such error.

            jglick Jesse Glick added a comment -

            Sergey Chipiga your problem (IllegalStateException: Invalid object ID 2 iota=14) looks unrelated and should be filed separately.


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                ycollet yann collette
              • Votes:
                5 Vote for this issue
                Watchers:
                16 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: