Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19453

Slave launcher fails after NoClassDefFoundError: Could not initialize class jenkins.model.Jenkins$MasterComputer

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      Core versions: Jenkins-1.509.2, Jenkins-1.509.3, Jenkins-1.509.4-RC
      Master: Windows server 2007 SP1; RHEL6
      Slave: Linux Mint 64 bits; Windows 7 (JNLP)
    • Similar Issues:

      Description

      I am able to start slave.jar via ssh or via jnlp.
      The log of the connection shows that the node is correctly started.
      In a project, I have 2 main parts:

      • a svn checkout
      • a shell command to start cmake + compilation.

      If I launch my build, it hangs. Then, I disabled the svn checkout and leave only the shell command with a "echo hello".
      If I start the build, it hangs with the following error message:

      Started by user anonymous
      [EnvInject] - Loading node environment variables.
      Building remotely on slave_linux_64 in workspace /home/crystal/jenkins/workspace/TESTLinux
      FATAL: command execution failed
      java.io.IOException: Remote call on slave_linux_64 failed
      at hudson.remoting.Channel.call(Channel.java:723)
      at hudson.Launcher$RemoteLauncher.launch(Launcher.java:862)
      at hudson.Launcher$ProcStarter.start(Launcher.java:353)
      at hudson.Launcher$ProcStarter.join(Launcher.java:360)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:91)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:60)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      at hudson.model.Build$BuildExecution.build(Build.java:199)
      at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:586)
      at hudson.model.Run.execute(Run.java:1603)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:247)
      Caused by: java.lang.NoClassDefFoundError: Could not initialize class jenkins.model.Jenkins$MasterComputer
      at hudson.Launcher$LocalLauncher.<init>(Launcher.java:755)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:991)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:965)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at hudson.remoting.Engine$1$1.run(Engine.java:63)
      at java.lang.Thread.run(Thread.java:724)
      Build step 'Execute shell' marked build as failure
      Finished: FAILURE

      When I looked at the jenkins directory I configured on the slave, all the required jar are present, the workspace directory is present and the build directory is correctly created by the jenkins master. But nothing in this directory.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                ycollet yann collette
              • Votes:
                5 Vote for this issue
                Watchers:
                16 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: