Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36991

Unable to load class once the loading was interrupted

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      Jenkins 1.609.3, remoting 2.52
    • Similar Issues:

      Description

      Jenkins.instance in groovy console yields:

      java.lang.NoClassDefFoundError: Could not initialize class jenkins.model.Jenkins
      	at java.lang.Class.forName0(Native Method)
      	at java.lang.Class.forName(Class.java:191)
      	at Script1.class$(Script1.groovy)
      	at Script1.$get$$class$jenkins$model$Jenkins(Script1.groovy)
      	at Script1.run(Script1.groovy:1)
      	at groovy.lang.GroovyShell.evaluate(GroovyShell.java:580)
      	at groovy.lang.GroovyShell.evaluate(GroovyShell.java:618)
      	at groovy.lang.GroovyShell.evaluate(GroovyShell.java:589)
      	at hudson.util.RemotingDiagnostics$Script.call(RemotingDiagnostics.java:142)
      	at hudson.util.RemotingDiagnostics$Script.call(RemotingDiagnostics.java:114)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      	at hudson.remoting.Request$2.run(Request.java:326)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      

      Following happened earlier in slave log:

      Slave.jar version: 2.52
      This is a Unix slave
      Evacuated stdout
      Slave successfully connected and online
      Jul 27, 2016 8:36:57 AM jenkins.model.Jenkins <clinit>
      SEVERE: Failed to load Jenkins.class
      hudson.remoting.RemotingSystemException: java.lang.InterruptedException
      	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:266)
      	at com.sun.proxy.$Proxy5.fetch3(Unknown Source)
      	at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:171)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at com.thoughtworks.xstream.XStream.buildMapper(XStream.java:590)
      	at com.thoughtworks.xstream.XStream.<init>(XStream.java:568)
      	at com.thoughtworks.xstream.XStream.<init>(XStream.java:496)
      	at com.thoughtworks.xstream.XStream.<init>(XStream.java:465)
      	at com.thoughtworks.xstream.XStream.<init>(XStream.java:411)
      	at com.thoughtworks.xstream.XStream.<init>(XStream.java:350)
      	at hudson.util.XStream2.<init>(XStream2.java:88)
      	at jenkins.model.Jenkins.<clinit>(Jenkins.java:4217)
      	at java.lang.Class.forName0(Native Method)
      	at java.lang.Class.forName(Class.java:191)
      	at Script1.class$(Script1.groovy)
      	at Script1.$get$$class$jenkins$model$Jenkins(Script1.groovy)
      	at Script1.run(Script1.groovy:1)
      	at groovy.lang.GroovyShell.evaluate(GroovyShell.java:580)
      	at groovy.lang.GroovyShell.evaluate(GroovyShell.java:618)
      	at groovy.lang.GroovyShell.evaluate(GroovyShell.java:589)
      	at hudson.util.RemotingDiagnostics$Script.call(RemotingDiagnostics.java:142)
      	at hudson.util.RemotingDiagnostics$Script.call(RemotingDiagnostics.java:114)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      	at hudson.remoting.Request$2.run(Request.java:326)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.InterruptedException
      	at java.lang.Object.wait(Native Method)
      	at hudson.remoting.Request.call(Request.java:147)
      	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:253)
      	... 30 more
      

      I dare to say it is another incarnation of JENKINS-19453, where classloading is interrupted and never reattempted.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            src/main/java/hudson/remoting/RemoteClassLoader.java
            src/test/java/hudson/remoting/ClassRemotingTest.java
            http://jenkins-ci.org/commit/remoting/fe2feffc943bfebae5a7b86d920962f78ca13777
            Log:
            [FIXED JENKINS-36991] Do not give up on classloading if loading is interrupted (#94)

            • [FIXED JENKINS-36991] Do not give up on classloading if loading is interrupted while fetching ClassRefference
            oleg_nenashev Oleg Nenashev added a comment -

            Released in remoting 2.61, which is available in the latest LTS


              People

              • Assignee:
                Unassigned
                Reporter:
                olivergondza Oliver Gondža
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: