Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
    • Environment:
      v1.593, amazon linux, v1.609.3
    • Similar Issues:

      Description

      Several paths in the Jenkins System Config won't save. I don't see any errors in the log either. Sometimes when I change fields, but always after save and go back to config my jdk home will be set to 'git' not the correct path.

      JDK is just an example. Many others are not saving properly: android home, gradle home, jenkins home URL, etc...

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Are you sure they're not saved to disk? Check the respective XML config files to make sure.

            Important: Don't go back to a form using the 'Back' feature (e.g. button, or pressing backspace) of your web browser, there's some known brokenness involved in that, so don't trust the values that are shown in that case (and never submit that either).

            danielbeck Daniel Beck added a comment -

            Clearly not about the JDK parameter plugin…

            robpark Rob Park added a comment -

            Agreed not about the JDK plugin... sorry, it was a required field and I didn't realize "core" was the right choice.
            Also, yeah, definitely not using the back button or any kind of resubmit.

            If I only change the JDK path, yes it will save to the jenkins config.xml, but if I change anything about the android plugin it will be wiped out.
            But I don't believe it's specific to the android plugin either. The gradle plugin has the same problem as does Jenkins location, and hipchat build server url.

            I haven't been able to establish a true pattern though. It's challenging where the UI always sets the name back to 'default' and the directory to 'git'.

            Thanks.

            danielbeck Daniel Beck added a comment -

            Rob Park Is this still an issue for you, or was it perhaps resolved by a Jenkins update?

            robpark Rob Park added a comment -

            Yes. It is still an issue. The upgrade did not resolve the problem. And since I've just been mostly avoiding updates there until I have time to build another server.

            danielbeck Daniel Beck added a comment -

            Check the permissions of the XML files in JENKINS_HOME. They should all belong to the same user and have rw permissions. That user should be the one Jenkins is running as.

            Go to the /log/all URL in Jenkins. Anything interesting there?

            goettl Georg Öttl added a comment -

            We also get the same error for Jenkins ver. 1.609.3. From time to time, when we save the Main config (we have a rather big config), the paths and configurations get scrambled or set wrong. We then have to manually restore the config. No errors in the logfile. Our suspicion is that this scrambling of the configuration happens somewhere in the javascript on the client side, before it is sent back to the server.

            danielbeck Daniel Beck added a comment -

            There's a known, long-standing bug with the config forms not handling use of the 'Back' button in the browser well. I.e. Navigate to form -> Submit -> Back -> Submit will break things. Looks like this is a duplicate of that issue.


              People

              • Assignee:
                Unassigned
                Reporter:
                robpark Rob Park
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: