Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27188

BUILDID and BUILD_TAG from previous project

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
    • Environment:
      Windows 7 64Bit, jenkins 1.600
    • Similar Issues:

      Description

      Since the update to jenkins 1.600 every project has the BUILDID and BUILD_TAG from previous project:

      BUILD_DISPLAY_NAME=#1964
      BUILD_ID=442
      BUILD_NUMBER=442
      BUILD_TAG=jenkins-ImageVision_1-442
      BUILD_URL=http://heilbutt:8080/job/DiaShow_Easy/1964/

      While I'm not happy that for some time now the BUILD_ID has been the same number as the BUILD_DISPLAY_NAME instead of a timestamp, this new discrepancy needs to be fixed quickly.

        Attachments

          Issue Links

            Activity

            Hide
            danielbeck Daniel Beck added a comment -

            A user reported this issue affecting Jenkins 1.602. Does anyone watching this issue know anything about that?

            Show
            danielbeck Daniel Beck added a comment - A user reported this issue affecting Jenkins 1.602. Does anyone watching this issue know anything about that?
            Hide
            raspy Krzysztof Malinowski added a comment -

            I also experienced this (or related) issue with 1.602. PATH variable is being messed up from different jobs and/or nodes. Using EnvInject 1.91.1, downgraded to 1.90 didn't fix the issue. Reverting core to 1.598 fixes behavior immediately.

            Show
            raspy Krzysztof Malinowski added a comment - I also experienced this (or related) issue with 1.602. PATH variable is being messed up from different jobs and/or nodes. Using EnvInject 1.91.1, downgraded to 1.90 didn't fix the issue. Reverting core to 1.598 fixes behavior immediately.
            Hide
            danielbeck Daniel Beck added a comment -

            Krzysztof Malinowski Please file a new issue and provide as much detail has you can. https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue

            Show
            danielbeck Daniel Beck added a comment - Krzysztof Malinowski Please file a new issue and provide as much detail has you can. https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue
            Hide
            raspy Krzysztof Malinowski added a comment -

            Actually it's rather JENKINS-27197 which was duplicated to this issue. Moreover, you asked if it is still visible, so I reported. If you prefer another issue for this behavior, I can raise a new one.

            Show
            raspy Krzysztof Malinowski added a comment - Actually it's rather JENKINS-27197 which was duplicated to this issue. Moreover, you asked if it is still visible, so I reported. If you prefer another issue for this behavior, I can raise a new one.
            Hide
            danielbeck Daniel Beck added a comment -

            If you prefer another issue for this behavior, I can raise a new one.

            Yes please. Unless the environment variables mentioned in the original report are still broken for you, it's a different (but possibly related) issue.

            Show
            danielbeck Daniel Beck added a comment - If you prefer another issue for this behavior, I can raise a new one. Yes please. Unless the environment variables mentioned in the original report are still broken for you, it's a different (but possibly related) issue.

              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                pfennig59 Kerstin Thaler
              • Votes:
                4 Vote for this issue
                Watchers:
                15 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: