Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2931

git tag freezing job execution

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I'm using Hudson ver. 1.270 with git version 1.5.2.3, there is a problem when I
      run a build, the command <git tag -a -f hudson-cms-10 -m "Hudson Build #10"> is
      issued and git does not recognize the -m parameter and tries to open Vim
      "freezing" the job. I've tested the command myself and if you change the
      parameter order to <git tag -a -f -m "Hudson Build #10" hudson-cms-10> it works.

      Is that anything I can do to workaround this issue? Is it my git version supported?

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : jbq
            Path:
            trunk/hudson/plugins/git/src/main/java/hudson/plugins/git/GitAPI.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=14836
            Log:
            [FIXED JENKINS-2931] git tag freezing job execution

            jbq jbq added a comment -
                • Issue 3447 has been marked as a duplicate of this issue. ***

              People

              • Assignee:
                jbq jbq
                Reporter:
                fernandolfs fernandolfs
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: