Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31450

org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact: Failure uploading archive to server

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Labels:
      None
    • Environment:
      Jenkins 1.635, Websphere Deployer version 1.3.4, Redhat linux 6.7, Firefox and Java 1.8
    • Similar Issues:

      Description

      Hi,

      I can connect to remote WAS ND 8.x and run a deployment of EAR file but got the error

      Started by user Nhu Nguyen
      Building in workspace D:\Bitnami\jenkins-1.635-1\apps\jenkins\jenkins_home\jobs\Projects\jobs\BAMS eBAMS\jobs\Delivery\jobs\Deploy to UAT\workspace
      Unable to find a build for artifact copy from: Projects/BAMS eBAMS/Developer Jobs/Basic Maven Build
      Connecting to IBM WebSphere Application Server...
      The following artifacts will be deployed in this order...
      -------------------------------------------
      bo-business-ear-4.7.0.1.ear
      -------------------------------------------

      Deploying 'bo-business-ear-4.7.0.1' to IBM WebSphere Application Server

      Error deploying to IBM WebSphere Application Server: org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact: Failure uploading archive to server
      at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:251)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:227)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:201)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)

      Build step 'Deploy To IBM WebSphere Application Server' changed build result to FAILURE
      Notifying upstream projects of job completion
      Finished: FAILURE

      I checked also the output from Jenkins server and found

      Nov 09, 2015 2:18:54 PM hudson.model.Run execute
      INFO: Projects/BAMS eBAMS/Delivery/Deploy to UAT #22 main build action completed: SUCCESS
      Nov 09, 2015 2:18:54 PM com.ibm.websphere.management.AdminClientFactory
      WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props
      Nov 09, 2015 2:19:11 PM hudson.model.Run execute
      INFO: Projects/BAMS eBAMS/Delivery/Deploy to UAT #23 main build action completed: SUCCESS
      Nov 09, 2015 2:19:11 PM com.ibm.websphere.management.AdminClientFactory
      WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props
      Nov 09, 2015 2:19:38 PM hudson.model.Run execute
      INFO: Projects/BAMS eBAMS/Delivery/Deploy to UAT #24 main build action completed: SUCCESS
      Nov 09, 2015 2:19:38 PM com.ibm.websphere.management.AdminClientFactory
      WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props
      Nov 09, 2015 2:19:56 PM com.ibm.ws.management.filetransfer.client.FileTransferClientImpl
      AUDIT: ADFS0109E: FileTransferClient failed to get server configuration information: java.security.PrivilegedActionException: javax.management.RuntimeOperationsException: The "name" parameter cannot be null.
      at com.ibm.ws.security.auth.ContextManagerImpl.runAsSystem(ContextManagerImpl.java:5608)
      at com.ibm.ws.management.filetransfer.client.FileTransferClientImpl.sendGetServerConfigRequest(FileTransferClientImpl.java:2539)
      at com.ibm.ws.management.filetransfer.client.FileTransferClientImpl.initialize(FileTransferClientImpl.java:2389)
      at com.ibm.ws.management.fileservice.FileTransferFactory.getFileTransferClient(FileTransferFactory.java:166)
      at com.ibm.ws.management.application.client.AppInstallHelper.copyToServer(AppInstallHelper.java:1240)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at com.ibm.websphere.management.application.AppManagementProxy.uploadArchive(AppManagementProxy.java:718)
      at com.ibm.websphere.management.application.AppManagementProxy.installApplication(AppManagementProxy.java:507)
      at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:237)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:227)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:201)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: javax.management.RuntimeOperationsException: The "name" parameter cannot be null.
      at com.ibm.ws.management.AdminClientImpl.assertObjectNameValid(AdminClientImpl.java:340)
      at com.ibm.ws.management.AdminClientImpl.invoke(AdminClientImpl.java:209)
      at com.ibm.ws.management.filetransfer.client.FileTransferClientImpl$1.run(FileTransferClientImpl.java:2536)
      at com.ibm.ws.security.auth.ContextManagerImpl.runAsSystem(ContextManagerImpl.java:5599)
      ... 22 more
      Caused by: java.lang.IllegalArgumentException: The "name" parameter cannot be null.
      ... 26 more

      Cuold you please help to check this issue?

      Thanks,

        Attachments

          Issue Links

            Activity

            nhunguyen Nhu Nguyen added a comment -

            All necessary setup have been completed:

            • Firewall ports have been opened (SOAP 45017)
            • Dummy client key & trust file of dmgr are copied to Jenkins server (a default untrusted certificate of WAS I think)
            • The DNS/IP is exactly setup
            nhunguyen Nhu Nguyen added a comment - - edited

            The WAS console port 9043 was opened on firewall to allow connectivity from Jenkins server to remote WAS server

            gpeters Greg Peters added a comment -

            You must specify the "node" "server" and "cell" in the configuration.

            gpeters Greg Peters added a comment -

            Not an issue

            jmoyer Jessica Moyer added a comment -

            We are getting the following error.  Jenkins will uninstall the ear fine, but will not deploy the ear.  Any ideas?

             

            org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact:

                            at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:251)

                            at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:227)

                            at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:201)

                            at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)

                            at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)

                            at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:690)

                            at hudson.model.Build$BuildExecution.post2(Build.java:186)

                            at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:635)

                            at hudson.model.Run.execute(Run.java:1752)

                            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)

                            at hudson.model.ResourceController.execute(ResourceController.java:97)

                            at hudson.model.Executor.run(Executor.java:429)

             

            Build step 'Deploy To IBM WebSphere Application Server' changed build result to FAILURE

            gpeters Greg Peters added a comment -

            Specifically to this issue, you must use the fully qualified domain name (FQDN) that the SSL certificate specifies. If you're deploying on WAS ND, use the DMGR SSL certificate, if you're deploying to a standalone WAS instance, use the administration consoles SSL certificate. The setting in the jenkins job for the DNS/IP of the server should match the server listed in the SSL certificate.


              People

              • Assignee:
                gpeters Greg Peters
                Reporter:
                nhunguyen Nhu Nguyen
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: