Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3265

Reload Configuration from Disk (or POSTing config.xml) loses info on running builds

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Platform: PC, OS: Windows XP
    • Similar Issues:

      Description

      Executing the "Reload Configuration from Disk" while builds are running causes
      information about those builds to be lost.

      POSTing a new configuration to /job/JOBNAME/config.xml also causes the exact same problem. Yet editing job configuration interactively using the web form does not show the problem.

      I had two builds running when I reloaded configuration to pick up manual changes
      to one project (not running a build) config.xml file. When the browser
      refreshed, the builds were still shown as actively building in the Build
      Executor Status frame but the status indicators were no longer blinking and the
      project pages did not show any builds running for those projects.

      It appears that part of Hudson thought that the builds had been canceled because
      they were queued, blocked by themselves. The original builds appeared to
      finsish normally and then the queued builds ran. There was no record of the
      original build that had been running when the config reloaded.

      Note: If Jenkins is completely restarted, by shutting down and starting up the service, the missing build re-appears. (Of course, doing that each time is unacceptable, just trying to help focus the debugging.)

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            src/main/java/hudson/plugins/promoted_builds/JobPropertyImpl.java
            src/test/java/hudson/plugins/promoted_builds/ConfigurationRoundtripTest.java
            src/test/resources/hudson/plugins/promoted_builds/ConfigurationRoundtripTest/testLoad/config.xml
            src/test/resources/hudson/plugins/promoted_builds/ConfigurationRoundtripTest/testLoad/jobs/j/builds/2012-10-08_10-29-01/build.xml
            src/test/resources/hudson/plugins/promoted_builds/ConfigurationRoundtripTest/testLoad/jobs/j/config.xml
            src/test/resources/hudson/plugins/promoted_builds/ConfigurationRoundtripTest/testLoad/jobs/j/promotions/OK/builds/2012-10-08_10-30-11/build.xml
            src/test/resources/hudson/plugins/promoted_builds/ConfigurationRoundtripTest/testLoad/jobs/j/promotions/OK/config.xml
            http://jenkins-ci.org/commit/promoted-builds-plugin/8147deb58e583ba696cd7feb451b1afabcb15a3d
            Log:
            Merge pull request #24 from jglick/NPE-JENKINS-17341

            [FIXED JENKINS-17341] NPE after JENKINS-3265 fix.

            Compare: https://github.com/jenkinsci/promoted-builds-plugin/compare/8f07c80a678d...8147deb58e58

            jmiller joe miller added a comment -

            We are still seeing this issue on 1.518 but only occasionally. Is anyone else seeing it?

            Unfortunately we have not identified any particular characteristics of how or when this happens or if there is anything of note about the jobs it is happening with. If anyone has suggestions for things to look for to help diagnose the problem that would be most helpful.

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #2710
            JENKINS-3265 JENKINS-17341 Even if older plugins throw an NPE during reload, continue loading job. (Revision ef08900292726bb35be269ce6d41d8dc141c6dea)

            Result = SUCCESS
            Jesse Glick : ef08900292726bb35be269ce6d41d8dc141c6dea
            Files :

            • core/src/main/java/hudson/model/AbstractProject.java
            mpapo Michael Pailloncy added a comment -

            Hi all,

            Exactly the same problem : reload the config from disk cause current running builds to disappear after reload but the build directory is present on the disk.

            Environment: Jenkins 1.593 on RHEL 6.0

            danielbeck Daniel Beck added a comment -

            Please keep issues as old as this resolved/closed.

            So please file a new issue. Make sure it also happens on the current weekly release, as there've been possibly relevant changes since 1.593. Provide all the information asked for on https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue and try to provide a minimal test case with clear instructions how to reproduce the problem.


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                pcampbell pcampbell
              • Votes:
                28 Vote for this issue
                Watchers:
                48 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: