Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33591

Manual steps broken in Jenkins ver. 1.653

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: build-pipeline-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.653
      Build Pipeline Plugin ver. 1.5.1
    • Similar Issues:

      Description

      Steps to reproduce

      1. Create a pipeline with a manually triggered step
      2. Trigger the step and wait until it's completed
      3. Refresh the view

      Expected result

      The manual step should be shown in green.

      Actual result

      The manual step is shown in cyan, as if it was not executed as a part of this pipeline.

      More information

      The issue seems to be caused by changes to CauseAction, as described in the comments of JENKINS-33467.

        Attachments

          Issue Links

            Activity

            dalvizu Dan Alvizu added a comment -

            Merged and released in 1.5.2

            giuspen Giuseppe Penone added a comment -

            Dan Alvizu sorry for the delay I was in holiday.
            About issue #1 yes you understood correctly, I see, so I have to run the job from the build pipeline view or it will not work (acceptable even though this way there's no way to run parameterised jobs).
            About issue #2 this is a show stopper for me because, since I have to run from the view, the job fails with the error of missing BUILD_USER_ID (https://wiki.jenkins-ci.org/display/JENKINS/Build+User+Vars+Plugin doesn't seem to work when running the job from the view)
            I'm running Jenkins LTS 1.642.3 and the just released version 1.5.2 of the Build Pipeline Plugin.
            I see you tested Jenkins 1.646 and 1.654 though saying that Build User Vars Plugin works there, if that is the case I'll just have to wait until they update the LTS.
            Many thanks for your support.

            dalvizu Dan Alvizu added a comment -

            The testing I did was:

            Create upstream job
            Create downstream job

            The only time 'BUILD_USER_ID' appears in the downstream job is if i check 'Set Jenkins User Variables' in the downstream job. In my testing it is never passed down from the upstream job. Do you know of a version where this isn't the case?

            dalvizu Dan Alvizu added a comment -

            If you can reproduce please include the job config.xml and the versions you used so I can take a look.

            giuspen Giuseppe Penone added a comment -

            Thanks Dan Alvizu for your help, I finally managed to have the Build User Vars Plugin working properly also when manually triggering the build from the view.
            I started testing on a virtual machine with Ubuntu 14.04 LTS with Jenkins 1.642.4 and it worked immediately.
            After upgrading the production environment to Jenkins 1.642.4 anyway it didn't work immediately, I made many tests trying to understand what was wrong, it seems to me that it started to work after I deleted every single build from the downstream manually triggered job and then from the view I triggered the build that went green with the BUILD_USER_ID variable properly created.
            Thanks again for the support.


              People

              • Assignee:
                dalvizu Dan Alvizu
                Reporter:
                noidi Timo Mihaljov
              • Votes:
                8 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: