Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38190

Repository Connector fail to recuperate the parameter ${version} from maven repsitory artifact

    Details

    • Similar Issues:

      Description

      Hello,

      We are using repository-connector plugin (version 1.1.3) for resolving maven repository artifact in jenkins 2.11. When I launch the "build with parameters", it succeed to give me the release versions stored in Nexus 2.12.0.01. But after choosing a version and building the job, it fails with the following error: (org.jenkinsci.plugins.tokenmacro.MacroEvaluationException: Unrecognized macro 'version' in '${version}')
      For more details please check the attached files.
      I am looking for your help.

      Best regards

        Attachments

        1. Artifact Resolver.png
          Artifact Resolver.png
          17 kB
        2. Build.png
          Build.png
          4 kB
        3. Error-Build.PNG
          Error-Build.PNG
          27 kB
        4. maven-repository-artifact.PNG
          maven-repository-artifact.PNG
          8 kB
        5. POM.xml
          4 kB

          Issue Links

            Activity

            Hide
            bilel_krichen Bilel Krichen added a comment -

            Hi,
            I have the same problem,anyone can need Help us

            Show
            bilel_krichen Bilel Krichen added a comment - Hi, I have the same problem,anyone can need Help us
            Hide
            yosra_ak yosra AKROUT added a comment -

            hello,

            I have the same problem too, can you help us please.

            Thank you.

            Show
            yosra_ak yosra AKROUT added a comment - hello, I have the same problem too, can you help us please. Thank you.
            Hide
            ghassen_khalil Ghassen Khalil ATI added a comment -

            Same criticial problem here !

            Show
            ghassen_khalil Ghassen Khalil ATI added a comment - Same criticial problem here !
            Hide
            toufik_medhaffar toufik medhaffar added a comment -

            I have the same problem too, can you help us please.
            help please

            Show
            toufik_medhaffar toufik medhaffar added a comment - I have the same problem too, can you help us please. help please
            Hide
            darwiin Christophe ROGER added a comment - - edited

            Same problem here. Unable to deploy on production using jenkins because of this. Please help us.

            Show
            darwiin Christophe ROGER added a comment - - edited Same problem here. Unable to deploy on production using jenkins because of this. Please help us.
            Hide
            amine_mz Amine MZ added a comment - - edited
            Show
            amine_mz Amine MZ added a comment - - edited Duplicate with #36149 : https://issues.jenkins-ci.org/browse/JENKINS-36149

              People

              • Assignee:
                Unassigned
                Reporter:
                mariem_baccar mariem baccar
              • Votes:
                6 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: