Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42216

Pipeline job offers inapplicable SCM on initial 'Pipeline from SCM' config

    Details

    • Similar Issues:

      Description

      Possibly bug in CpsScmFlowDefinition, or a Stapler issue.

      Install Pipeline and TFS Plugin. Create a Pipeline job. TFVC is offered in the 'Pipeline from SCM' when it shouldn't be, as it's missing the checkout(Job) override (and doesn't override isApplicable(Job)).

      Configure 'Pipeline from SCM: None", Apply, and reload. It will select Git, as it's the only applicable one now (NullSCM isn't either).

        Attachments

          Issue Links

            Activity

            Hide
            jglick Jesse Glick added a comment -

            CpsScmFlowDefinition.DescriptorImpl.getApplicableDescriptors needs to use StaplerReferer.findItemFromRequest.

            Show
            jglick Jesse Glick added a comment - CpsScmFlowDefinition.DescriptorImpl.getApplicableDescriptors needs to use StaplerReferer.findItemFromRequest .
            Hide
            abayer Andrew Bayer added a comment -

            Throwing this on my to-do list - the actual change is trivial, but I need to take the time to write a WebClient test to actually verify it works. And I'm not in the mood at the moment, so I'll do it later. =)

            Show
            abayer Andrew Bayer added a comment - Throwing this on my to-do list - the actual change is trivial, but I need to take the time to write a WebClient test to actually verify it works. And I'm not in the mood at the moment, so I'll do it later. =)
            Hide
            karanva Karolina Arancibia Valuskova added a comment - - edited

            Ran into the same issue, is there a work-around until this is solved? my problem is exactly like the duplicate on this issue.
            This is blocking the build of the job, since it throws a Null Pointer when it tries to find the scm even though I specified it as 'None'

            Show
            karanva Karolina Arancibia Valuskova added a comment - - edited Ran into the same issue, is there a work-around until this is solved? my problem is exactly like the duplicate on this issue. This is blocking the build of the job, since it throws a Null Pointer when it tries to find the scm even though I specified it as 'None'

              People

              • Assignee:
                abayer Andrew Bayer
                Reporter:
                danielbeck Daniel Beck
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: