Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56555

Remoting error, missing class: hudson/remoting/Channel$IOSyncer

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      CentOS 6.10, Java 1.8u101, Linux 2.6.32-754.9.1.el6.x86_64
    • Similar Issues:

      Description

      I see issues with remoting constantly.

      I've been gradually upgrading Jenkins - I assume the slave.jar has the new remoting code too, all slaves are ssh-slave to Linux machines.

      When I get this the job in question often hangs forever.

      <===[JENKINS REMOTING CAPACITY]===>@@^@channel started
      Remoting version: 3.17
      This is a Unix agent
      Evacuated stdout
      Agent successfully connected and online
      Mar 14, 2019 8:36:01 AM hudson.Launcher$RemoteLaunchCallable$1 join
      INFO: Failed to synchronize IO streams on the channel hudson.remoting.Channel@76ccd017:channel
      java.lang.NoClassDefFoundError: hudson/remoting/Channel$IOSyncer
      at hudson.remoting.Channel.syncIO(Channel.java:1679)
      at hudson.Launcher$RemoteLaunchCallable$1.join(Launcher.java:1315)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:927)
      at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:901)
      at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:850)
      at hudson.remoting.UserRequest.perform(UserRequest.java:210)
      at hudson.remoting.UserRequest.perform(UserRequest.java:53)
      at hudson.remoting.Request$2.run(Request.java:364)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.ClassNotFoundException: hudson.remoting.Channel$IOSyncer
      at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      ... 17 more

        Attachments

          Issue Links

            Activity

            jthompson Jeff Thompson added a comment -

            An inability to load classes from the remoting (agent) jar likely has the same root causes, even though the class causing problems is different.

            Closing as a duplicate of the other.


              People

              • Assignee:
                jthompson Jeff Thompson
                Reporter:
                craigemery Craig Emery
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: