Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56560

Slave logs full of remoting error: "unable to read a command"

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      CentOS 6.10, Java 1.8u121 from JRE in JDK 1.8.0_121, Linux 2.6.32-754.9.1.el6.x86_64
    • Similar Issues:

      Description

      <===[JENKINS REMOTING CAPACITY]===>channel started<===[JENKINS REMOTING CAPACITY]===>channel startedRemoting version: 3.17This is a Unix agentEvacuated stdoutAgent successfully connected and onlineMar 14, 2019 10:04:16 AM hudson.remoting.SynchronousCommandTransport$ReaderThread runSEVERE: Unable to read a command (channel channel)java.lang.ClassNotFoundException: hudson.remoting.ProxyOutputStream$Ack at java.net.URLClassLoader.findClass(URLClassLoader.java:381) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:348) at java.io.ObjectInputStream.resolveClass(ObjectInputStream.java:677) at hudson.remoting.ObjectInputStreamEx.resolveClass(ObjectInputStreamEx.java:59) at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1819) at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1713) at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1986) at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1535) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:422) at hudson.remoting.Command.readFrom(Command.java:116) at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:35) at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:63)

        Attachments

          Issue Links

            Activity

            jthompson Jeff Thompson added a comment -

            ProxyOutputStream should be loadable.

            Check that your agent (slave) jar files are up-to-date and not corrupted or mismanaged.  Double-check your Java versions on master and agent. They need to be consistent.

            Here are some earlier issues similar descriptions. The solutions and discussion there might be relevant for you. JENKINS-4656, JENKINS-5149, JENKINS-29405

            jthompson Jeff Thompson added a comment -

            Since there has been a lack of response for quite a while on this, I'm going to close this issue. If you have additional information to help move this along, feel free to provide it and re-open as needed.


              People

              • Assignee:
                jthompson Jeff Thompson
                Reporter:
                craigemery Craig Emery
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: