Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6439

Timeline on BuildTimeTrend page does not work

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Hudson 1.355
    • Similar Issues:

      Description

      It seems to me that the graphical representation of the build time trend is not in the place it should be (see attached screenshot).

        Attachments

        1. BuildTimeTrend.jpg
          BuildTimeTrend.jpg
          373 kB
        2. JENKINS-6439.patch
          2 kB
        3. JENKINS-6439-2.patch
          0.7 kB
        4. ScreenShotWithTwoDataPoints.jpg
          ScreenShotWithTwoDataPoints.jpg
          61 kB
        5. Timeline_NewBuilds.jpg
          Timeline_NewBuilds.jpg
          210 kB
        6. TimelineMissingDataWrongHour.jpg
          TimelineMissingDataWrongHour.jpg
          120 kB

          Issue Links

            Activity

            dsoa D Soa added a comment -

            I attached another screenshot from a different project. It shows 2 data points, so it isn't limited to just the latest. Still off by 1 hour.

            dsoa D Soa added a comment -

            Upgraded to 1.540. Same problem.

            dsoa D Soa added a comment -

            Checked a few other projects and a pattern has emerged. All builds before 6pm CST the previous day are missing from the graph. That's midnight GMT. So only builds from the current "GMT day" are shown (and then displayed one hour later than they happened).

            dsoa D Soa added a comment -

            This looks like the reason for the off by one hour problem:
            https://github.com/jenkinsci/jenkins/commit/f6ac62bfba80093b9cf3957b5055fcce2a15002a
            <j:invokeStatic var="tz" className="java.util.TimeZone" method="getDefault"/>
                var tz = $

            {(tz.rawOffset + tz.DSTSavings) / 3600000}

            ;
            The "fix" must have been made while we were in daylight savings time. Now that we aren't, it doesn't work.
            The timezone offset can only be calculated when given a Date as a time of reference.

            danielbeck Daniel Beck added a comment -

            D Soa: This issue has been resolved and confirmed to be fixed years before you reopened it.

            Just file a new bug for the similar but clearly different issue you're seeing (if it still occurs in a recent version of Jenkins).


              People

              • Assignee:
                Unassigned
                Reporter:
                starfury starfury
              • Votes:
                27 Vote for this issue
                Watchers:
                26 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: