Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27530

ISE from RunMap.put after reloading configuration from disk

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      The dead node is Win7 running cygwin sshd, the server is RHEL5. Jenkins version 1.605.
    • Similar Issues:

      Description

      Submitting log per instructions on the dead node page.

      Unexpected executor death
      java.lang.IllegalStateException: /hfs/d1/local/jenkins/jobs/test_other/builds/96 already existed; will not overwite with test_other #96
      at hudson.model.RunMap.put(RunMap.java:187)
      at jenkins.model.lazy.LazyBuildMixIn.newBuild(LazyBuildMixIn.java:178)
      at hudson.model.AbstractProject.newBuild(AbstractProject.java:1006)
      at hudson.model.AbstractProject.createExecutable(AbstractProject.java:1205)
      at hudson.model.AbstractProject.createExecutable(AbstractProject.java:144)
      at hudson.model.Executor.run(Executor.java:213)

        Attachments

          Issue Links

            Activity

            hai_lh hai li added a comment -

            Anyone could fix this critical issue?

            jglick Jesse Glick added a comment -

            Seems like there may be two distinct issues:

            • A bug in the reload function relating to stale Job objects, with clearest steps to reproduce in JENKINS-29902, and analysis in JENKINS-33794.
            • Some bug in the matrix-project plugin’s implementation of MatrixConfiguration.getNextBuildNumber and .assignBuildNumber overrides, which looks like an intrinsically fragile design.
            jglick Jesse Glick added a comment -

            Jeff Miller

            If "Reload Configuration from disk" isn't going to be fully supported then it should be removed entirely.

            It has always been trouble-prone and I would love to remove it, but it seems there are a fair number of people relying on it.

            It is safer to reload an individual job via the reload-job CLI command or POSTing to $JENKINS_URL/job/whatever/reload.

            Better still is to avoid touching $JENKINS_HOME directly at all, and use update-job etc. to modify configurations from scripts.

            jglick Jesse Glick added a comment -

            I have a fix for the reload-with-job-in-queue bug. Might make it into 2.13. Might make it into 2.7.2 or 2.7.3.

            dima kovalenko I tried to follow your instructions to reproduce the related bug in Jenkins 2.7.1 without success. Are you still able to reproduce it? If so, it would be best to file a fresh bug report in matrix-project-plugin, linked to this one, with exact steps to reproduce from scratch.

            Mark Waite similarly.

            jglick Jesse Glick added a comment -

            Fixed towards 2.13.


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                igorama Igor Koyfman
              • Votes:
                9 Vote for this issue
                Watchers:
                20 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: