Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23152

builds getting lost due to GerritTrigger

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: gerrit-trigger-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.554.1
      GerritTrigger 2.11.1
    • Similar Issues:

      Description

      When viewing jobs, newer builds disappear from the build history list. Trying to go to the URL of a newer build results in a 404. The missing builds are located on disk and restarting Jenkins will make them reappear.

      Sometimes, the nextBuildNumber is set to a lower number and duplicate builds are created; two date-directories are created in builds/ but only the latest build has a build_number symlink.

      I wrote tool to help detect these problems on disk and even repair them (for some value of repair): https://github.com/docwhat/jenkins-job-checker

      A lot of history is on JENKINS-15156; I'll repeat some of it below.

        Attachments

          Issue Links

            Activity

            batmat Baptiste Mathus added a comment - - edited

            FWIW, same or similar issue seen here too on Jenkins 1.593 (+Jenkins Gerrit plugin 2.12.0 and a 2.8.3 Gerrit server). It seems to have happened since we used reload from disk (which we do only few times a year) and only affects Gerrit builds.
            Even when triggered manually with the "query & trigger Gerrit Patches", we see the new build displayed on the left of the screen. But it does not appear in the job page and leads to a 404 when accessed. And the build is indeed on the disk and seems to run just fine. So more something like a GUI issue.

            Will post more informations here if we manage to reproduce the issue non randomly.

            rsandell rsandell added a comment -

            And what happens if you upgrade to >= 2.13 where efforts have been made to fix this?

            batmat Baptiste Mathus added a comment -

            rsandell We plan to upgrade our instance quite soon, we'll see it this comes back. Thanks for the feedback.

            canoztokmak Can Oztokmak added a comment -

            upgrading gerrit plugin to 2.14.0 resolved our issue.

            rsandell rsandell added a comment -

            Version 2.13.0


              People

              • Assignee:
                rsandell rsandell
                Reporter:
                docwhat Christian Höltje
              • Votes:
                7 Vote for this issue
                Watchers:
                23 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: